BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Video Widget stopped working on Version 2.28.7

This has been a repeating issue - from upgrade to upgrade the video widget stops working with a standard MJPEG stream.
It has been working (albeit unreliable) with 2.27.17, but stopped working completely on 2.28.7
Any of the trickery that used to make it work on 2.27 does not work anymore on 2.28
Could you please have a look?

The underlying stream is an MJPEG stream which is activated within 100ms of the WiFi client connection. VLC/Browsers are working fine with the stream.

Link to the streaming code: GitHub - arkhipenko/esp32-mjpeg-multiclient-espcam-drivers: ESP32 MJPEG Multiclient Streaming Server with latest Espressif drivers

@BlynkAndroidDev

Pete.

2.28.x is the beta channel for a different video support implementation, and it can break sometimes. Try the latest stable 2.27.x it should handle MJPEG. Also please send a log from 2.28.x version - I will check what has gone wrong.

I’ve uploaded a new beta version with some fixes to strange issues with trying to play video as mjpeg.

Still does not work on 2.28.8 - sent the logs to developer.

so my old galaxy s4 says its version 2.26.6. does not work. uses arkhipenkos code. want logs?

edit: dont know why i wrote iphone. its an old galaxy s4

I think the sweet spot was version 2.27 - it “kinda” worked :slight_smile:

You can leave beta channel and install 2.27.x version if it works better for you

According to logs, app receives an error when trying to get mjpeg stream:

java.net.SocketException: Connection reset
Thrown to indicate that there is an error in the underlying protocol such as a TCP error

However, when I copy the URL and paste it into the chrome browser on the same very phone everything works great…

@arkhipenko I’m testing with this next link: https://iihrwc03.iowa.uiowa.edu/axis-cgi/mjpg/video.cgi?resolution=704x480 - does it work on your side?

Also have you tried to leave beta channel and install 2.27.28 version?

Yep, and that version works on my device

So can you use 2.27.28 ? 2.28.x has not been meant to be a stable branch, I will fix it later when there will be time for it.

Yes I can.
However, the beta design was more appealing… :frowning_face:

There are no changes in design between 2.27.x and 2.28.x. Only different video streaming libraries and enabled logs.

I’ve added new 2.28.9 versions with FFmpeg-based video streaming

Hi, my rtsp stream not working now… Does the streaming url stay the same or do I need to change it?

Your device model?

Have you tried to enable or disable “force tcp”?

Hi, Thankyou for your advice. I have tried both setting however still not working… Here is the details of the camera.

The streaming url is

rtsp://ipaddress:portNo./user=admin_password=password_channel=1_stream=1.sdp?real_stream