Using openssl cert with blynk server

hi @Dmitriy I’ve been using blyk https api commands successfully for a while but now I get a connection refused since I updated by local blynk server to 0.24.3 .

I’m using windows 10 as my server OS and I am using my own certificates I created using openssl (not signed by a CA). The lets encrypt does not work for me due to my local network configuration i.e. I have a web server on port 80 already.

Has there been a change to the local server that would break using openssl (without signed certificates) ?

some additonal info from my logs : I’m now using blynk local server : 0.24.6
Note: do I need to TURN off automatic certificate generation if I have created my own via OPENSSL ?

20:31:55.934 INFO - Didn't find Let's Encrypt certificates.
20:31:55.934 INFO - Automatic certificate generation is turned ON.
20:31:57.502 INFO - Hardware plain tcp/ip server listening at 8442 port.
20:31:57.505 INFO - Hardware SSL server listening at 8441 port.
20:31:57.506 INFO - Application server listening at 8443 port.
20:31:57.508 INFO - HTTP API and WebSockets server listening at 8080 port.
20:31:57.509 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
20:31:57.510 INFO - Mqtt hardware server listening at 8440 port.