BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Uno+wifi atmega 328P esp8266 does not comunicate with blynk app

you can have AT firmware or a sketch in esp, not both. for Blynk on Uno+WiFi upload AT firmware to esp8266 and Blynk sketch to ATmega328p

I know

so then don’t use EspSoftwareSerial in ATmega sketch, it is not a SoftwareSerial to ESP, it is a SoftwareSerial for ESP

@Juraj i suspect that we’re being trolled here, by Ms Phisher :thinking:

Pete.

1 Like

I get this error

ets Jan 8 2013,rst cause:2, boot mode:(1,7)

they say it`s power related or reset who is not fully reset

I have a power adapter of 12V 3A connected

you have wrong boot pins state. you have gpio 0 LOW so the esp8266 goes into flashing mode. (the 1 in “boot mode” tells me this. it should be 2.) switch the dip switch for esp8266 flashing mode to off. and then switch the USB to ATmega and upload the Blynk sketch. (assuming you didn’t delete the AT firmware with attempts to upload sketch to esp8266)

thanks verry mutch, it works

why does it go to 74880 baudrate?

now i get this error

ets Jan 8 2013,rst cause:2, boot mode:(3,7)
after that it says ready but does not yet connect en get en error from blynk

[1623] ESP is not responding

i wired the RX TX correctly

74880 is only the baud rate of the esp8266 bootloader log. (it would be 115200 with 40MHz crystal but esp8266 modules usually have 26 MHz crystal).
the Blynk example uses 38400 baud so the AT firmware should be set to this baud rate too.
http://help.blynk.cc/en/articles/605485-esp8266-with-at-firmware

don that dit not work

get error 1620 esp not responding

now i saw at the page you send firmware to put it in modem mode!

the firmware it has a link to is not there anymore is it the latest 1.5.4 this on i had installed?

Is there a AT function call to set it to modem mode?

the article calls AT firmware ‘modem mode’. so switch the switches, flash the AT firmware and set the buadrate, then switch back to ATmega

Yea it works

after using this link

Please tell me Full Problem in details . ReWrite the post .
I Use Arduino + NodeMcu
Arduino + Esp12-E Module Standalone
Arduino + Esp8266 Module Standalone
all are works perfectly . i faced a simple problem . that was declaration of Rx Tx pin . i changed rx tx pin and works good. tell me the problem in details.

I have solved the problemen it was do to serial libary and a circuit who configuraties the arduino
CH PD to 3.3V for initilazing I think and resistors for voltage division TX arduino to Rx esp and while doing Dat put arduino in programing mode

Thanks everybody how do I put this topic to solved