Unable to connect

I am trying to connect my arduino uno using W5100 Ethernet Shield running the Arduino Ethernet example to the blynk cloud but I am unable to do so!

The output in the serial monitor shows:

Connecting to cloud.blynk.cc:8442

And then after some time again the same message!

Using blynk library 0.2.4

@Aks297

Try “telnet cloud.blynk.cc 8442” it could be problem on your router.

@Dmitriy
Sir,
On trying the telnet!
I am getting an error-
Unable to connect on port 23: Connection failed

Now, what to do, please help :expressionless:
(Sorry, I don’t have extensive knowledge about networking)

@Aks297 is that your home router? Some routers may have closed ports. telnet usually may say if port open or not.

Yes, its my home router!
How to check whether the port is open or not?

@Aks297

So telnet is supposed to tell that. So when you typing “telnet cloud.blynk.cc 8442” you should see something like

Connecting To cloud.blynk.cc…

In case after that you see empty screen with cursor - that’s means everything is ok and you connected. Otherwise you will see some error. So please try it and tell me results. Also please check that your windows firewall doesn’t block your connection. The problem is for sure in your network envirnoment or system.

@Dmitriy
Sir,
On trying the telnet!
I am getting an error-
Unable to connect on port 23: Connection failed
Tried this with the firewall disabled too!
But not working!

Now, what to do, please help :expressionless:
(Sorry, I don’t have extensive knowledge about networking)

Unable to connect on port 23: Connection failed

I says you try to telnet port 23. But you need to input 8442. “telnet cloud.blynk.cc 8442”

Sir,
Tried with 8442
I am getting a black screen with a blinking cursor !
(On windows)

Please give me your email (via personal messge) so I could check your logs.

Sent the email id to you!

Don’t see any errors… So let’s start from the begging. Download latest Blynk library, remove old Blynk library and replace with new one. Run Basic ethernet sketch with your token. Enable debug and tell me what is happening.

[0] Blynk v0.2.5-beta
[0] Getting IP…
[5530] My IP: 192.168.1.103
[5531] Connecting to cloud.blynk.cc:8442
[20558] Connecting to cloud.blynk.cc:8442
[35581] Connecting to cloud.blynk.cc:8442

and this goes on and on…

code that I have used:

#define BLYNK_DEBUG
#define BLYNK_PRINT Serial    
#include <SPI.h>
#include <Ethernet.h>
#include <BlynkSimpleEthernet.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "pasted my token here";

void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth);
}

void loop()
{
  Blynk.run();
}

@Aks297

All seems ok. I don’t know if that helps but maybe you need to make port forwarding on your router? At least you may try, it could help. In case you don’t know what is that just google “port forwarding your_router_model”

But what should I write in the local IP address column (on the port forwarding page)? As I am using Ethernet shield which is assigned an IP automatically (DHCP)!

Or should I try to configure the ethernet shield manually in my arduino sketch?

You could enter this one :

[5530] My IP: 192.168.1.103

Let’s just check if that’s a case.

And start port number and end port number as 8442?

Yeap. Or you could put range like 0 - 10000

Tried port forwarding!
No luck either :frowning: