Unable to connect to local server

Help. I’m trying to connect to my local server running on my pi zero W. My Android is not connected to the internet but it’s Wi-Fi is hooked up to the pi zero’s hotspot where the blynk server is running. The blynk app keeps saying the 8442 Port is not open.

I read on a different topic that I need a new account to work with a local server. How true is this?
I have my server.properties and mail.properties all configured yet I’m met with this error. Anybody know how I can get out of this jam?

It is a good idea to keep updated with all Announcement Topics.

The port for Devices is now 8080 and for the App it is 9443

Very true… think needing a different account if you change banks, etc.

You need to log into your server via your App (linked to your server IP address, NOT Blynk cloud), create a new account and start making (or copying previously cloned) projects.

Fast forward couple weeks later, I’ve managed to connect my blynk app to my local server But can’t start projects until I figure out where exactly I’m to paste the authentication code emailed to me? No tutorial or forum answer have been clear on that.

Do you mean this one?

Check the docs:

1 Like

My project is on the raspberry pi. I checked out the docs link you posted, the problem i was having was that the url provided to download node js on the docs was not compatible with the armh chip of the raspberry pi. It returned this error so curl -sL "https://deb.nodesource.com/setup_6.x" | sudo -E bash - returned this error:

You appear to be running on ARMv6 hardware. Unfortunately this is not currently supported by the NodeSource Linux distributions. Please use the ‘linux-armv6l’ binary tarballs available directly from nodejs.org for Node.js 4 and later.

I solved that by finding the the matching version for my pi and i installing as i type this. Will post back if i run into more complications.

Perhaps more clarity on exactly what you are trying to do…

  • Your Local Server is on a RPi Zero W - Unknown server version, unknown Linux version
  • You couldn’t connect with App (using incorrect 8442 port instead of 9443) - Fixed
  • Yo don’t know where to put the Auth code - First where/what is your client device? The same RPi, another RPi, Arduino, esp, etc? If the same or another RPi, what are you intending to use for the client… WiringPi, NodeJS, Python?..

My client device is the same raspberry pi. I’m comfortable with python so i want to be able to use blynk actuators like switches and relays. I’ve installed nodejs. Where do i go from here?

Well, if you are comfortable with Python, then use Python not NodeJS

NOTE, if you want to use your Local Server with Python, then after installing it you need to locate BlynkLib.py…

Possibly found here: /home/<your user name>/.local/lib/python2.7/site-packages/BlynkLib.py

And edit this line with your Server IP and port…

class Blynk:
    def __init__(self, token, server='**xxx.xxx.xxx.xxx**', port=**8080**, connect=True, ssl=False):

Wow… Okay I’m gonna test that out.

Hi guys, I’m yet to create any project on a local server. I need some more clarifications…

Does my Pi Zero W need to act as an access point for the local server to work?
Or will it work if my pi is connected to the same network (wireless router) my Android is also conneted too?

The reason I ask is that I had to flash my SD card that had a working hostapd setup and since then I have not been able to get the access point working. I’ve spent too much time on setting up hostapd and now I need to move on.

No. Your router can handle all that. You just point your App and devices to the IP of the Pi (provided by your router). Use port 9443 for the App and port 8080 on the devices.

Its done. Thanks @Gunner.

pip install blynk-library-python did not work. The error says “could not find a version that satisfied the requirement blynk-library-python (from versions : ) No matching distribution found for blynk-library-python”