Unable to add new device

hello everyone!!
I am using nodeMcu v1.0 (esp8266)
I was trying to control an led over internet with blynk server. But i was unable to add device from blynk iot android application. i have uploaded blynk edgent esp8266 example code in nodemcu, and led light on board of nodemcu is blinking as it should as it is ready to connect. but on mobile application on pressing ready button it remains scanning and don’t show the device, also while trying to connect it mannualy sometimes the wifi name of nodemcu(in my case it is Blynk iot led-219A6) is not visible and other time i am unable to connect to the network.

on serial monitor it just shows wait_config.

Android app version?
Blynk library version?

It’s best if you copy/paste your serial output rather than posting a partial screenshot.


blynk library version is 1.0.1
blynk iot android app version is 1.2.2(46)(04.09.2021 21:55)
android version is 9 PKQ 1.180904.001(Mi note 7s)(miui 11.0.9)

serial monitor:

___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v1.0.1 on ESP8266

[393] --------------------------
[396] Product: IoT led
[398] Firmware: 0.1.0 (build Sep 25 2021 23:09:45)
[403] Device: ESP8266 @ 80MHz
[406] MAC: 84:CC:A8:AE:A6:31
[409] Flash: 4096K
[411] ESP core: 3.0.2
[413] ESP SDK: 2.2.2-dev(38a443e)
[416] Boot Ver: 6
[417] Boot Mode:1
[419] FW info: 467936/1626112, MD5:c59c8090d945cd7cd583c91582ba7fe3
[626] Free mem: 31272
[626] --------------------------
[1237] AP SSID: Blynk IoT led-219A6
[1237] AP IP:
[1238] AP URL: blynk.setup

the thing is mobile phone is unable to connect to Blynk wifi

Could you please send us the logs from your mobile app? (“Person icon” in the top left corner)

Have you found a solution? I had similar issues with a new batch of your type of board that went away a bit magically by: shortening the SSID name (yours looks fine,32chars seems the limit) then getting rid of spaces in the SSID. Then it showed up as an AP with “Blynk Device-number” during Edgent provisioning. After that I can introduce spaces again just fine. Sorry this is a bit random…or desperate? After I did all that every other device I tried after reconfiguring it (via the three dots top left in app)…worked ok. I hope non scientific magic works fo you too.