BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Twitter widget not sending tweets

#22

@BlynkAndroidDev, @Dmitriy, @vshymanskyy or @Eugene,

Would one of you please help us understand the situation as it relates to the Twitter widget. Would you please acknowledge that it’s not working in conjunction with the cloud server. Would you please let us know if this bug will be fixed or whether the Twitter widget is being retired.

Thank you,

Joe

1 Like

#23

Hello. We will check. From your side you need to check if your account is active, you don’t send the same message in your tests, you don’t exceed message limit.

0 Likes

#24

Thank you, @Dmitriy!

The problem could (in theory) be my Twitter account, however, I guarantee the issue is not sending the same message more than once (I always include a timestamp in each message) and I’m not exceeding the message limit.

To the broader Blynk Community … is the Twitter widget working for you (with the cloud server)? On either platform? With any firmware version?

0 Likes

#25

As stated in my OP, I thoroughly tested the Twitter functionality when I made the post (though haven’t tried using it since). It worked before in the same manner (with a timestamp to make every tweet unique) and even a brand new account didn’t make a difference. Using the original code didn’t make a difference either.

I’m using the cloud, not a local server. More information regarding versions and hardware can be found in the OP.
All the things Dmitriy mentioned were functioning correct in my case.

If I can be of any help let me know. Good luck devs!

0 Likes

#26

@PeterNL, Your OP was clear and comprehensive. I basically followed the exact same steps. The Twitter widget isn’t working for @Gunner and @maxxir. I was just wondering if the Twitter widget is currently working for anyone. I’m sure @Dmitriy will help us sort this out.

1 Like

#27

You are abusing name tagging. Please stop doing that. Once someone is in the topic, they get notifications.

0 Likes

#28

Issue confirmed. Twitter had limited our application due to high update rate. Waiting for response from twitter.

0 Likes

#29

Not by default. I receive Notifications when someone directly replies to my post, when someone “Likes” my post and when someone identifies me in a post using @wickedbeernut. Note: I received a notification when Dmitriy replied to my post on this topic. However, I didn’t receive a notification when you posted to the topic complaining that I was abusing tagging. You didn’t reply to me, nor did you include @wickedbeernut. Obviously, you didn’t “Like” my post. :wink: Consequently, I wasn’t notified. I’ve never changed my Notifications settings. This is the default behavior. This is the difference between Tracking a topic (default) and Watching a topic. I could change my settings from,

image

to,

image

however, this won’t change the way in which the vast majority of your Community Members receive Notifications. I don’t believe I’m abusing “name tagging”. I believe I’m using it exactly the way it was intended to be used. I’d be happy to use it more sparingly.

0 Likes

#30

The Twitter Widget is working again. Thank you!

0 Likes

#31

The squeaky wheel gets the tweet fixed :smiley:

0 Likes

#32

Unlike other community members, Blynk crew is monitoring every post. Also, you can use reply button under the comment (not topic) instead of name tagging.

Considering how many tags we get, any unnecessary one is abusive.

Thanks for understanding.

0 Likes

#33

Twitter is indeed working again. Wasn’t sure if I still had it active in my sketch but just checked the feed because Gunner mentioned it worked and my Controllino is indeed sending tweets since 18 hours ago.

Thanks for everyone’s help & support, especially the devs ofcourse. :slight_smile:

0 Likes