Tried Everything ! Please Help an enthusiastic beginner ! Still getting "Failed to Disable Echo"

Hello Everyone
Sorry again for raising this question again.

But I am really stuck . I have tried to find a solution for “failed to Disable Echo”

I am a new user , I know nothing about it, but I really need your help as I am trying to use blynk v0.3.4 libraries with Arduino Uno and ESP8266 and I keep getting the message
[1014] Blynk v0.3.4
[1515] Connecting to Taran
[2531] Failed to disable Echo

when I run the below code. I have Tried to make all the connections and everything as shown in the fig . Please help me out with some detailed guidance as I am absolutely new here and have to submit a wifi controlled Robot next week .

Also I do not have any USB converter or any other sort of method to connect ESP directly to PC. I only have it cnnected to Arduino using Rx and Tx Pins.

I am really a new user , tried to find a lot of solutions to fix it but couldnt. So I have come to this forum finally . Please help me out in a detailed manner . I request.

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266_SoftSer.h>
#include <BlynkSimpleShieldEsp8266_SoftSer.h>

// Set ESP8266 Serial object
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(2, 3); // RX, TX

ESP8266 wifi(EspSerial);

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "ec910e42439846c294e338cf02d8ec3e";

#define m11 8
#define m12 9
#define m21 10
#define m22 11

void forward()
{
  digitalWrite(m11, HIGH);
  digitalWrite(m12,LOW);
  digitalWrite(m21,HIGH);
  digitalWrite(m22,LOW);
}

void backward()
{
  digitalWrite(m11, LOW);
  digitalWrite(m12,HIGH);
  digitalWrite(m21,LOW);
  digitalWrite(m22,HIGH);
}

void right()
{
  digitalWrite(m11, HIGH);
  digitalWrite(m12,LOW);
  digitalWrite(m21,LOW);
  digitalWrite(m22,LOW);
}

void left()
{
  digitalWrite(m11, LOW);
  digitalWrite(m12,LOW);
  digitalWrite(m21,HIGH);
  digitalWrite(m22,LOW);
}

void Stop()
{
  digitalWrite(m11, LOW);
  digitalWrite(m12,LOW);
  digitalWrite(m21,LOW);
  digitalWrite(m22,LOW);
}

void setup()
{
  // Set console baud rate
  Serial.begin(9600);
  delay(10);
  // Set ESP8266 baud rate
  // 9600 is recommended for Software Serial
  EspSerial.begin(9600);
  EspSerial.write("AT0\r\n");
  delay(1000);

  Blynk.begin(auth, wifi, "Taran", "taran2794");  // wifi username and password
  pinMode(m11, OUTPUT);
  pinMode(m12, OUTPUT);
  pinMode(m21, OUTPUT);
  pinMode(m22, OUTPUT);
}

BLYNK_WRITE(V1) 
{
  int x = param[0].asInt();
  int y = param[1].asInt();

  // Do something with x and y
/*  Serial.print("X = ");
  Serial.print(x);
  Serial.print("; Y = ");
  Serial.println(y);*/
  if(y>220)
  forward();
  else if(y<35)
  backward();
  else if(x>220)
  right();
  else if(x<35)
  left();
  else
  Stop();
}

void loop()
{
  Blynk.run();
}

I’d guess from what you’ve said that the ESP-01 isn’t set-up to communicate at the 9600 baud that your Uno is using.
You really need a USB to serial adapter to be able to do his, and you can’t really use anything faster than 9600 baud with SoftwareSerial.

You also need a separate power supply for your ESP-01, with the ground connection shared with your Uno.

Pete.

I need to use my Arduino for my robot .

But can you please guide me on which ESP i should use then for communicating over Wifi ? And if the same can be achieved using the adapter that you talk of , can guide me with a link on which one is it ? And how to configure using it ?

Is there a way i can fix the baud rates on both the arduino and esp to the same value and make it work ?

Also why does this issue arise ? ‘FAILED TO DISABLE ECHO’ . ? could you please guide me a little more ?

You need to be able to connect your ESP-01 to your computer, using a USB to serial adapter, so that you can issue a series of AT commands to toset its baud rate to 9600. You’ll find plenty of information about how to do that on this forum, or on the internet.

You could use one of these, which makes it easy to plug an ESP-01 in directly:

or one of these that is more flexible for future use, but less convenient when using the ESP-01:

From what I’ve read, the ‘failed to disable echo’ message really means ‘the ESP-01 didn’t respond’, which is exactly what would happen if the ESP was using a different baud rate.

Don’t ignore my comment about a separate PSU, it’s important!

Pete.

In a pinch, you can your your own UNO as a TTL-USB adapter. In this situation you need to connect the ESP and UNO like this TX<->TX & RX<->RX (NOTE: this is the opposite of the normal crossover connection needed when using the ESP as a shield).

Then all you need to do is jumper the UNO’s RESET pin to GND your UNO will simply act as a USB-TTL passthrough for whatever ESP flashing software or terminal you use (untested, but possibly the IDE’s Serial monitor may also work for the AT commands?)

1 Like

Hi, Thanks a lot for this info. But I am again stuck and really need your help .

I bought the first product that you have given me the link for USB to ESP8266 Serial Programmer Module board for ESP-01.

But I connected it to the computer and opened the seial monitor .

But as soon as I send ‘AT’ it gives me just a single message ‘ERROR’ .

Can you please guide me on how to set up the serial connection using the Arduino IDE , is there any sketch code that I need to use ? How do I set up the serial monitor to accept my AT commands because I basically need to change the BAUD rate to 9600 for software serial.

I cannot find a guide which tells how to connect it to the system using this programmer board. And neither can I find a guide which shows which code to use or which sketch to use OR if it is to be even used or not. So can you please guide me again ? point me to the right link ?

Thanks a lot once again , I am just stuck here with the usb programmer module and the ESP 8266. don’t know how to use it with arduino ide.

Is there a sketch to be uploaded to this ESP8266 using the programmer module before using AT commands? If yes , can you please help me with that ?

Thanks a lot once again and sorry for the trouble.

DO NOT upload any sketch to the ESP-01, it will overwrite the original AT firmware and you’ll need to re-flash it with a copy of the latest AT firmware.

Here are some basic instructions, they assume that you’re using the Arduino IDE…

Unplug the ESP-01 USB/Serial adapter from your PC

Start the Arduino IDE and Choose Tools then Port. You’ll see a list of available serial ports. This will probably just have one port - COM1

Plug the ESP-01 USB/Serial adapter into your PC

In the Arduino IDE Choose Tools then Port again (this list doesn’t auto refresh) and you should see that another serial port has appeared. Choose this new COM port

In the top right hand corner of the Arduino IDE, click the magnifying glass icon to open the serial monitor.

In the toolbar at the bottom of the serial monitor, select 115200 as your baud rate, Type AT in the text area at the top of the serial monitor and click Send (or hit return). You should see a response like this:

image

If you get no response, or a response that prints out random characters then you’re using the wrong baud rate. Try working your way through the baud rates and re-issuing the AT command until you get a response.

You can then issue the correct AT commands to permanently change the baud rate of the ESP-01 to 9600 (do a bit of searching, and increase your 41 minutes of time spent reading the forum, and you’ll soon see how to do this)

If you don’t see the new COM port when you plug the ESP-01 USB/Serial adapter then you probably need to install the correct driver for the USB chipset on the Serial adapter.

If you’ve done all of this and still get an ERROR response to a simple AT command then I’d say that your ESP-01 is probably faulty or damaged. It could have suffered ESD damage if you’ve not handled it carefully.

Pete.