BLYNK
BLYNK.IO       📲 GETTING STARTED       đź“— DOCS       👉 SKETCH BUILDER

Timer widgets not able to select integer type datastream

Hi All,

I am not able to select the integer type datastream for the timer widgets. It is allowing string type only… in my app it is also not showing a similar screen as shown in the help Documentation for Blynk, the most popular IoT platform for businesses.. Looks like there is some issue with this. I can see only start and stop time selection & week of the day selection.

in the sample code, it shows that we will get high/1 or low/0… if it is type string then not sure what value it will be sent when start? https://github.com/blynkkk/blynk-library/blob/master/examples/Widgets/Timer/Timer.ino

Did anyone try this example in the help? not sure if I am doing something wrong… I am using iOS App, I tried with Android App as well same issue there in Adroid App as well. Pls help.

That’s a link to the Legacy documentation, which doesn’t use datastreams.

That’s for the Legacy Timer widget, not the IoT Time Input widget.

The Legacy Timer widget has been replaced by Automations in IoT.

Is suggest you read the correct documentation…

https://docs.blynk.io/en/

Pete.

Hi Pete,

Thanks for sharing the details about Automation… it is very helpful. When we use automation what should be the code running in the hardware? Can I use the same code as timer.ino or we need to run different code in hardware?

Have you tried reading the documentation?

Pete.

Used the same code as in timer example and it is working fine… thanks for help!