Timer Widget on different devices

I use Blynk on a phone and a tablet but try to limit it to one device at a time.

When the phone is not running Blynk and I change the times in the Timer Widget and press the Play icon it doesn’t appear to be processing the widget correctly. I can understand that the App will get confused if 2 devices are logged in at the same time and you change the Timer Widget settings. On the phone with the tablet logged out the Timer Widget is working fine.

Both devices are Samsunsg’s. An S3 with Android 4.4.4. and a GT-P5110 (Tab 2 10.1) with Android 4.2.2.
Come to think of it I’m not sure the tablet has every responded to the timer widget.

Has anyone else experienced this or have a fix?

I haven’t tried the share App with a friend as my app is not quite finished but I’m guessing friends will not be able to change the time settings in the widget.Obviously we don’t want friends to be able to change the app but changing on / off times would be VERY useful. Saves us having to code timers ourselves.

I shared my project with my wife (Alcatel smartphone with Android 4.4.2) and the timer widget doesn’t function on that device either. It is the first project I have shared and I was a little surprised that I had to change the auth token in my Arduino Nano for it to work at all.

I guess auth tokens issues will be sorted for makers / families / businesses etc in due course.

So back to the timer widget. In the Alcatel phone it also provides seconds and AM and PM settings for the time setting. Tried AM and PM but still no response from the App. All the other features of the app are working fine.

I’m not sure why your timer is not working.
Need more details on that.

Customizing Timers and some other widgets in sharing mode is already planned. Thanks for pointing out.

Pavel I don’t really have anything other than what is in the thread already. 3 different devices with 3 different versions of Android. 1 works, 2 don’t. The timers don’t start at the set time.

Presumably the ‘time’ in question is the time on the Android phone rather than your server.

Are these 3 Android devies are under same Blynk account?

Is it within one project/many? Can we see the code?

How do you use the timer? How do you know it’s not working?

Have timer widget ever worked for you?

Timer Widget uses the time of the Smartphone it was set at.

This part is unclear at all. Could you please explain the process.


2 devices using the same account, 3rd device using shared project with a separate account. It is the original device that set up the project (Samsung S3) that works. At a given time my central heating comes on, when the timer widget works.
Yes the timer widget works (on 33% of my machines). I only have one real project so I can’t say if it is project specific.

Pavel the auth token was a separate observation on how you share projects. As others have pointed out not very useful for many real world applications. We want to sell thousands of devices with a single app being able to control all the devices. At present each device requires a different sketch.

Timer turns on/off something connected to an Arduino at a given time. Correct?

From what I understood: timer triggers the event(heating) which means that it works.

When you say it doesn’t work on 66% of my devices, what do you mean? You can’t change time? Time is not updated? Sorry, but It’s not clear for me.

When you say “share”, you mean you’ve used the QR code sharing or just logged in on wife’s phone with your credentials?

Arduino send 433 Mhz RF signal to my home heating system.

On 2 of the 3 devices when I set the time say 14:00 on and 14:10 off it doesn’t do anything at the allocated time. On the one device it does what my sketch requests i.e. sends the RF signal.

I tried to take photos of my dashboard but the pictures were rubbish. However taking photos of one Android with another Android has helped identify the timer problem.

Using the Samsung phone and Samsung tablet with a single Blynk account I noticed one of the tablet that wasn’t responding to the timer widget earlier is now accepting them. It is accepting the timer widget settings from the S3 phone. The time on the 2 devices is about 2 minutes apart and the tablet that is 2 minutes fast is activating the timer widget based on the time of the S3 phone rather than it’s own time, even though the timer widget settings were changed on the tablet.

Hope this helps identify the issue at your end.

Shared the official way, I don’t use QR but the tiny url your system provides.

Just to be clear on the sharing. The Alcatel device received the tiny url (QR) and the Samsung devices (phone and tablet) are using my single account, not my wife’s.

Can’t test the Alcatel (wife’s account) at present because of the ‘token issues’ but I suspect this may also be due to different times on the Android devices. I know it should take the time form the device the app is running on but it certainly doesn’t seem to when using one account on 2 devices, even with the ‘master’ logged out.

Just done further testing with the Samsungs using the SINGLE account.
S3 time is 16.06 and Tablet is 16.09. If I set Tablet to use the timer for 1 minute from 16:10 to 16.11 it WAITS until the time of the S3 reaches 16:10 to activate, thereby reading 16.12 on the tablet. This timing anomaly was the reason that the timers didn’t appear to be working when I tested them earlier.They are working but not based on the time of the device that the app is running on.

The Alcatel time is a further 5 minutes out so that probably explains why they weren’t working on that device either with a ‘QR’ shared app. Strange behaviour.

Thanks for all the clarifications.we’ll check on our end.

Sometimes it’s hard to identify the problem, that’s why there are so many questions. :wink:

Just to add I have checked the app sharing feature and I shared it to the Alcatel device with full access rather than just the ability to use the app. Obviously the timer widgets can’t be changed if I only give user access but I will take a look at this feature too so I have more of an idea how token work.

All 3 Android devices work! But they don’t work as per spec. Looks like they are taking local internet time rather than phone time. I thought all my Android devices were working to local internet time but oviously not as they are up to 6 minutes different. I suspect my main machine, the S3, is actually using local internet time but the others are not. That is why the S3 worked as expected but the others were not triggering as the time had already passed or was due t trigger many minutes after I expected them to.

In a real life situation this ‘feature’ is not too much of a problem as you would be setting the trigger times well into the future and wouldn’t notice if it triggered 5 minutes earlier than expected.

I will look to see if I can set all the Android devices to local internet time and this should work as a temporary fix.

Are triggers maybe being controlled by the time on the Blynk server and not the device’s internal time?

Yes they appear to be, even though we were told it was the time on the phone.
What it could be is that when the App first sees the Timer Widget it checks Blynk server time and works out how far in the future the timer should activate. If phone and Blynk servers have different times (i.e. not both updated by the internet) then the timer will start at the ‘wrong’ time.

Blynk needs to update us with what the ‘real’ time is for the timers.

Here is how timer works :

  • You setup a widget on your device using local time;
  • Local time converted to UTC;
  • When widget is saved (play button pressed) UTC time is send to server;
  • Server check timer, if now is correct time to trigger - server sends message to hardware if it is online.