Terminal Widget on Photon

I’m having trouble getting this guy going. Used the example code from Github for the terminal widget, but it doesn’t appear to be writing data back from the photon. I know that the Write(V1) function is getting called because I’m notified by the push widget. What am I missing here?

// This #include statement was automatically added by the Particle IDE.
#include "blynk/blynk.h"

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "xxxxxxxxxxxxxxxxxxxxxx";

// Attach virtual serial terminal to virtual pin 1
WidgetTerminal terminal(1);

void setup()
{
 // Serial.begin(9600);
  Blynk.begin(auth);

  while (Blynk.connect() == false) {
    // Wait until connected
  }

  terminal.println(F("Blynk v" BLYNK_VERSION ": Device started"));
  terminal.flush();
}


BLYNK_WRITE(V1)
{
  Blynk.notify("Terminal recieved Something!");
  terminal.print("I got:");
  terminal.write(param.getBuffer(), param.getLength());
  terminal.println();
  // Ensure everything is sent
  terminal.flush();
}

void loop()
{
  Blynk.run();
}

Have you selected V1 in App for terminal widget? If. yes try to comment “Blynk.notify” and check if it works without it.

Yes V1 is selected in the app. I commented out the push notice and flashed again. Now the photon is offline. I’m not near it at the moment, so I’m not sure why it’s offline. I had a similar experience with a core last night. It was working with other widgets, but when I tried an app with just the terminal widget it acted like it bricked it. Still not able to get the core working. Will look into this later.So after all of that I switched to the photon. Was able to flash the photon and it stayed online, but no response from the terminal. That’s why I added the push notice, so I could at least see if the code was executing. So far this is the only widget I’ve had any problems with.

@vshymanskyy could you please check

Update: I was able to get the Core and Photon back online. For the Core, I had to do a factory reset and connect with Coolterm to set the wifi credentials. It is now running an app that does not contain the Terminal Widget. For the Photon, I reset it into safemode and flashed the tinker app, then the original Blynk app in my first post (Still no response from the Terminal).

Hey rhino. I have a photon in hand, which hardware type did you config in blynk project? Particle core? Maybe I can give a try with Blynk on photon today

I tried both core and photon. The code in my original post is what I used on both (without the publish widget). I added the publish widget just to see if various parts of the code were executing. I’d be interested in what your results are, thanks.

Yay! I see with the last android update of Blynk the terminal works as expected! Thanks for looking into this.