Tab control erroneously constraining widget position (Android OS)


  1. new project with 2 controls.
  2. add tab control (automatically puts existing controls on tab 1).
  3. move one of the existing controls from tab 1 to tab 2.
  4. try to drag the control on page 2 over all possible locations within the tab.
    Despite being the only control on the tab, it cannot be dropped in some places. At first I thought it was just restricting tab 2 based on the control in tab 1, but then I moved both controls around and found that there are ghost restrictions (restrictions where controls USED to be, but aren’t anymore).

Blynk app version 2.14.6 on Nexus 7 Android 4.4 using public Blynk server.

Update: now I can’t get my project back to normal. Even with no tabs, existing controls cannot be moved to top left corner.

I can confirm similar placement issues with my MEmu emulator running Android v.4.2.2

But everything works fine on my Nexus 6 running v.7.0. and even my old Samsung Galaxy Tab 10.1" running a hacked update of v.5.1.1

THEN, I noticed that AFTER messing around on the two newer versions, when I came back to the MEmu, it allowed me to transfer widgets around as normal (on same previously problematic test project).

So, If I create a tab while in a newer Android OS, or at least log in and refresh the view from a newer OS version, then the older version has no problems moving and placing widgets from that time on.

The issue seems to be how the older versions of Android communicate with the server, when initiating tab additions/updates?


I was able to restore normal behavior of my non-tabbed project by killing the app and reloading. However, I have not tried this technique while tabs are present.

Could you clarify: there are restrictions based on now invisible widgets, or just zones on the tab at which you could not place your widget?

I’m not sure I understand the question. Are you saying “invisible widgets” exist? In any case, I had only 2 buttons and 1 terminal at the time; all visible. When I moved any of these items to tab 2, there were places I could not place them (like the top left corner), even though nothing else was on that tab. When I deleted the tab control, even my main screen had funky issues like that until I forced an app restart. I have not tried the tab control since then. It’s possible a restart would have cleared up the issue on tab 2.

Thanks, understood, we’ll investigate this issue after next release. I’ve thought from your first comment, that you had dragged a widget on second tab and then it became invisible