BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

SyntaxError - node-red-contrib-blynk-ws on Beaglebone Black

Hi Blynkonz - any ideas why this isn’t loading cleanly. I’m stumped, tried reinstalling it just doesn’t fully work.

I can’t get node-red-contrib-blynk-ws to work. It does install and Node Red runs but there is no server connection option and errors in NR log. The palette loads but with no option to select or create a server connection.

Am I missing a client node or something - have I done something silly?

Local server running on Beaglebone Black (server-0.41.10)
App on Android

Here’s some logs and screenshotz of the problem

    : Welcome to Node-RED
    : ===================
    : 19 Sep 00:39:47 - [info] Node-RED version: v0.19.6
    : 19 Sep 00:39:47 - [info] Node.js  version: v6.17.0
    : 19 Sep 00:39:47 - [info] Linux 4.14.71-ti-r80 arm LE
    : 19 Sep 00:39:51 - [info] Loading palette nodes
    : 19 Sep 00:39:56 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
    : 19 Sep 00:39:56 - [warn] rpi-gpio : Cannot find Pi RPi.GPIO python library
    : 19 Sep 00:40:30 - [info] Dashboard version 2.14.0 started at /ui
    : 19 Sep 00:40:31 - [warn] ------------------------------------------------------
    : 19 Sep 00:40:31 - [warn] [node-red-contrib-blynk-ws/blynk-ws-client] SyntaxError: Unexpected token ... (line:1)
    : 19 Sep 00:40:31 - [warn] [node-red-contrib-blynk-ws/blynk-ws-zergba] SyntaxError: Unexpected token ) (line:1)
    : 19 Sep 00:40:31 - [warn] [node-red-contrib-blynk-ws/blynk-ws-image-gallery] SyntaxError: Unexpected token ) (line:1)
    : 19 Sep 00:40:31 - [warn] ------------------------------------------------------
    : 19 Sep 00:40:31 - [info] Settings file  : /root/.node-red/settings.js
    : 19 Sep 00:40:31 - [info] Context store  : 'default' [module=memory]
    : 19 Sep 00:40:31 - [info] User directory : /root/.node-red
    : 19 Sep 00:40:31 - [warn] Projects disabled : editorTheme.projects.enabled=false
    : 19 Sep 00:40:31 - [info] Flows file     : /root/.node-red/flows_beaglebone.json
    : 19 Sep 00:40:31 - [info] Server now running at http://127.0.0.1:systemd/
    : 19 Sep 00:40:31 - [warn]```

And this - in the NR Manage Palettes menu 

node-red-contrib-blynk-ws
1.0.1

SyntaxError: Unexpected token ... (line:1)
SyntaxError: Unexpected token ) (line:1)
SyntaxError: Unexpected token ) (line:1)
Any help greatly appreciated

One for @gab.lau i think …

Pete.

@PeteKnight Yes!
The nodejs version must be at least 8.16!!
Then also node-red is not updated, I suggest you update it

best regards

1 Like

Sterling support.
Many thanks, I’ll give that a go.