SuperChart (binary) History not showing


I use the SuperChart (in binary mode) to show if a button is HIGH or LOW (1 or 0), and when I am in Live mode I can see the data showing but in 1h, 6h,… the data is always LOW.

P.S. When using History Graph widget, the data is visible (but of course averaged).

Kind Regards

I had a similar problem. The clock on my server was wrong by a few months :slight_smile:

Well I just now realized that it shows the data if I set the flipping value at 0, still trying to understand it… First what came into my mind is, I am not sending HIGH and LOW all the time (just when it happens) but then there is now the option “connect missing data points” which should handle this issue. And also, why is Live working in both cases (when flipping is at 0 or at 1)

P.S. My server time is fine, I monitor it all the time on my LCD Widget.

@Cejfi it will only connect data points if they exist. How often are you sending 0 and 1?

Every minute.

The server can’t graph textual data like HIGH and LOW even though ESP’s and Arduino’s understand the terms.

I call it HIGH and LOW, but its actually just 1 and 0 :stuck_out_tongue:

What does this mean?

In binary mode you can set the flipping value.

For example, you send the data in the range of 0 to 1023. If you set 512 as a FLIP point, then everything above 512 (including 512) will be recorded as TRUE, any value below 512 (excluding 512) will be FALSE.
Another example, if you send 0 and 1 and set 1 as a FLIP point, then 1 will be TRUE, 0 will be FALSE

So with a flip of 0 you are seeing the data but not with a flip of 1, right?


Which pin is the button connected to and is it an ESP?

Raspberry, but I really don’t think that I have a problem with the Hardware or data not arriving to the server.

Can you try to reproduce this?

I would say that the majority of Pi users don’t understand the pin numbering system.

Maybe you are in the minority.

@Cejfi actually this is bug in docs. Doc updated. Thanks for reporting.

@Dmitriy I tried a timer at 2s intervals to toggle between 0 and 1 and Live correctly shows the flip but 1h is showing it as permanently 1. I changed the timer to 3456ms just in case I was being unlucky with the reading cycles and it’s still showing as permanently 1.

@Dmitriy I checked the raw data for the 1h flip and it is still taking some average values between 0 and 1, as shown in green in the table below. Some values should round down to zero though?

Avaraging is still used in case you send more than 1 point per minute per pin. This is “free cloud” limitation.

@Dmitriy is this the required parameter in to make the change for none Blynk servers?

#period in millis for saving all user DB to disk.

@Costas Local server works in same way.