Stringify + Blynk - integrate your projects with other cloud services

Hi Blynk user community!

I’m Kris - an engineer at Stringify. We recently met with @Pavel to see what Blynk and Stringify users could create together!

Stringify is a cloud-to-cloud IoT automation platform that allows you to create very powerful automations… “If I arrive home, only if it’s after sunset, only if … [unlimited number of only if conditions], THEN turn on my Hue lights, THEN start a 10 minute timer, THEN turn them back off”. That’s just a small example - we offer math functions, variables (increment a variable, then if an variable < 5, do X), etc.

We support Nest, Hue, Wink, SmartThings, Insteon, and dozens of other physical things and digital services.

So… how do you integrate Blynk with Stringify?
Two ways:

  • Stringify offers the Connect:Maker thing. This will allow you to send an HTTP GET/POST to Stringify to trigger a flow, and we will send an HTTP GET/POST/PUT as an action - note these requests come from the cloud.
  • We’ve got a nodejs module that is designed to run on a Raspberry Pi (or anything else that runs nodejs). This includes three “plugins” - one that can set/get RPI GPIO pins, another that will send text-to-speech over the RPI’s speaker, and a third ‘generic template’ that you can use to connect to anything! This module is still in beta and currently is only available by sending me a message :slight_smile: (alternatively I can give you a full RPI image). Prior to making this request, I recommend people download Stringify and familiarize themselves with basic flow building, the concept of AND/OR in flows, etc. Links to our app can be found on our web site.



Has anyone successfully used the Stringify Maker channel with Blynk?

I’ve tried duplicating the IFTTT fields that I’ve successfully used to communicate to Blynk. The fields are mostly the same. I’ve specified a “PUT” action, duplicated the URL that I use in IFTTT, and specified “JSON Data” in the data type drop down menu. I’m guessing that the problem is with the formatting of the actual data. In the IFTTT body. ["1"] has always worked. I tried the same data in Stringify’s “Field 1 VALUE”, both with and without the brackets, but so far, haven’t been able to control any virtual pins on Blynk. Any ideas what I’m doing wrong?

Same problem!! :frowning_face:

It appears that users have tried to integrate this without success… so I have merged the two topics and changed the category until it is determined if this is a Blynk issue or a Stringify issue.

I’ve been having the same problem, I even tried the direct link like this (auth code hidden) with no body options.

Tried both PUT and POST, No Data and JSON

Like others say it works directly in the address bar and webhooks but not with stringify.

I think its a user error that we can’t find clear instructions for.