BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Something wrong with bridge widget

#1

Hi !

I noticed something weird with bridgewidget.

Sometimes when I upload my code to MCU1, I have to reset MCU2.
Else MCU1 bridge don’t receive data from MCU2 .

MCU1 ESP8266
MCU2 ESP32

0 Likes

#2

I recently noticed a change after either App or Library update, unsure which… Where a source project that send two bridge commands to two different projects suddenly stopped sending the 2nd one.

Turns out I was setting both bridges to the same vPin in the source project (and that always worked before and thus saved a vPin) but now it needs distinctly separate vPins for each widget. Those vPins are not used anywhere else in the source project or App so I grabbed the top end pins this time

Was…

WidgetBridge bridge1(V2); //Initiating Bridge Widget - For Bridge output to Mega
WidgetBridge bridge2(V2); //Initiating Bridge Widget - For Bridge output to ESP32/Nextion

Is now…

WidgetBridge bridge1(V126); //Initiating Bridge Widget - For Bridge output to Mega
WidgetBridge bridge2(V127); //Initiating Bridge Widget - For Bridge output to ESP32/Nextion

This might be related to your issue??

1 Like

#3

Thank you Gunner.
I only have bridge1(V0)
on the two MCU.(same code, different auth)
the issue is random.

0 Likes

#4

I have a constantly running sketch on an ESP32, that often loses Blynk Server connectivity, sometimes reconnecting it seems as the data is rarely too old, but generally I just reset it. It otherwise keeps running fine.

I often wonder it it is simply a ESP32 Core/Blynk ESP32 library thing? Or perhaps just my code :stuck_out_tongue: it is a Virtuino/Blynk/Nextion mix.

I have been meaning to add in a Bridged temp display (on the Nextion) from an external sensor MCU, so I will test and see if I run into same/similar Bridging issue.

1 Like

#5

Same thing for me.
This night esp32 lost the connection and the rec_count indicates 8 attempts to connect to blynk.
I think I have to increase the 30 seconds delay between 2 attempts.
Another weird thing, the 2 mcu restarted at 0:00 tonight.

0 Likes