BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

[SOLVED] Xmas Lights


#21

Sounds like you dont have FastLED installed?

http://fastled.io/


#22

Yes, that what you show me is just what I have, in my arduino \ ESP8266-WS28xx-Blynk folder. I have installed also wifi_credentials.h, in the libraries folder, and as Jamin said, when I open the .ino file, the settings.h file appears as a tab. In the Arduino ide.

I have checked all, and I do not see where the problem may be. What I don’t understand is why none of the FastLed examples,work in the ESP8266, and they work in the Arduino Nano.No problem, with the Adafruit Neopixel library.


#23

Although I don’t have a suitable ESP to load it into … yet :wink: I just duplicated the whole procedure as per @Jamin’s instructions, and it compiles OK.

So it appears to be something in your system setup… all I can suggest is double check your Arduino folder, remove the affected libraries, and reinstall, etc.

EDIT - perhaps show us the verbose error log in the IDE as well?


#24

Sorry,what do you mean?


#25

Perhaps you might also need to remove all the ESP core libraries (in the board manager) and reinstall… I did have an issue wherein I had an older one as well as 2.3.0 installed.


#26

Which part?


#27

Show you the verbose error log in the IDE as well.


#28

In IDE: File -> Preferences -> checkmark for verbose compilation.


#29

Ok,i’ll do it.


#30

I recommend you remove and do a clean install of the FastLED library first, possibly even that ESP core.


#31

Ok.


#32

The ESP core can be cleared by Tools -> Board: -> Board Manager. Filter search for ESP, and remove the ESP by ESP Community one (it should be 2.3.0), then search again, if another older version shows up, remove it as well.

Then redo the search and re install 2.3.0


#33

Thank you for your help.I’ll do it all tomorrow.


#34

These issues sound more like a library issue since he can’t get the FastLED examples to work?


#35

@Jamin I think you might be right… I first thought it might also be his ESP core becasue of this statement (above quote) about FastLED working with Arduino but not ESP… but upon reread, the Arduino worked with the Adafruit library… so not the same at all :wink:


#36

also, you should consider updating your ide. 1.6.9 is very old.

probably your current problem is not related to this, but generally it is advised to use the latest version.


#37

Good catch :+1:


#38

I still 1.6.9 because last time I updated, OTA broke on all my devices D:

“No Answer”


#39

OTA is fine with 1.8.3.


#40

I spent weeks trying to get this to work. Problem is the ESP continuously interrupts your neopixel code. I found a sledgehammer fix was to use the ESP, running blynk, connected to an Arduino Nano through I2C.
Works like a charm.