[Solved] Webhook problem

Dear Costas
I very much appreciate your help, however I am still having no results even with your code.
Is it possible something needs to change in the library to get it to work ? Something specific for NodeMCU ?
I am using Arduino IDE

Is there some debug info I can activate, since I am seeing nothing in my serial monitor except the three values, but no return.

Add the following lines as your second and third lines and then provide us with Serial Monitor details.

#define BLYNK_PRINT Serial // Defines the object that is used for printing
#define BLYNK_DEBUG        // Optional, this enables more detailed prints

Webhook is not fully functional widget. I tried to get help from Blynk founders and got nothing. I gave up webhooking with Blynk

Not accurate.

The webhook works fine for myself and a majority of Blynk’ers.
If you are experiences issues then it is a localised bug or user error.

I saw your previous posts from mid November and you never finished the discussion from the developers who were trying to help you.

I could also see a lack of understanding of Blynk basics.



I haven’t finish the discussion because lack of the help from developers. It’s waste of time for me.
Show me how to integrate Webhook widget with Thingspeak.com one of most popular IoT services. There is no response from the widget. That’s why I was asking for help (and still asking) Blynk offeres paid services, so it should be functional.

Dear Costas,

Hereby the log with the debug on. Sorry it took some time to get this , but here it is
As you can see, the button is pushed when the 3 numbers are showing in the log, but no return from the call

[253] Connecting to xxxxxxx
[7255] Connected to WiFi
[7255] IP: xxxxxxxxxxx
[7255] Blynk v0.3.9 on NodeMCU
[7255] Connecting to blynk-cloud.com:8442
[7285] <[02|00|01|00] xxxxxxxxxxxxxxx
[7344] >[00|00|01|00]È
[7344] Ready (ping: 41ms).
[7344] <[11|00|01|00]Hver[00]0.3.9[00]h-beat[00]10[00]buff-in[00]1024[00]dev[00]NodeMCU[00]build[00]Dec 29 2016 11:52:30[00]
[7365] >[00|00|01|00]È
[17365] <[06|00|02|00|00]
[17382] >[00|00|02|00]È
[27383] <[06|00|03|00|00]
[27402] >[00|00|03|00]È
[30327] >[14|00|01|00|02]
[30327] >pm
[34815] >[14]!4[00|06]
[34815] >vw[00]1[00]1
[34815] <[14]!4[00|18]vw[00]0[00]20151106[00]1358[00]20108
[44816] <[06|00|04|00|00]
[44836] >[00|00|04|00]È
[54835] <[06|00|05|00|00]
[54855] >[00|00|05|00]È
[64856] <[06|00|06|00|00]
[64874] >[00|00|06|00]È
[74875] <[06|00|07|00|00]
[74892] >[00|00|07|00]È
[84893] <[06|00|08|00|00]
[84909] >[00|00|08|00]È
[94910] <[06|00|09|00|00]
[94928] >[00|00|09|00]È
[104929] <[06|00|0A|00|00]
[104947] >[00|00|0A|00]È
[114948] <[06|00|0B|00|00]
[114965] >[00|00|0B|00]È
[124966] <[06|00|0C|00|00]
[124983] >[00|00|0C|00]È
[134983] <[06|00|0D|00|00]
[135000] >[00|00|0D|00]È
[145001] <[06|00|0E|00|00]
[145024] >[00|00|0E|00]È
[155025] <[06|00|0F|00|00]
[155046] >[00|00|0F|00]È
[165047] <[06|00|10|00|00]
[165063] >[00|00|10|00]È
[175064] <[06|00|11|00|00]
[175080] >[00|00|11|00]È
[185081] <[06|00|12|00|00]
[185097] >[00|00|12|00]È
[195098] <[06|00|13|00|00]
[195113] >[00|00|13|00]È
[205114] <[06|00|14|00|00]
[205137] >[00|00|14|00]È
[215138] <[06|00|15|00|00]
[215157] >[00|00|15|00]È
[225158] <[06|00|16|00|00]
[225174] >[00|00|16|00]È
[235175] <[06|00|17|00|00]
[235190] >[00|00|17|00]È

@Robert_Holscher try version 4.0 of the library as 3.9 is 3 months old.

I am currently using 4.0.

Hi Costas,

Does not make a difference. Tested with the just released library of blynk and with arduino 1.8 , but same result

Did you try 4.0?

I tried with 0.43 the latest library of blynk

@Jamin which library version are you using and are you using Blynk’s cloud server?

I am still on 0.4.0 and my webhook test was with a local server that is also a few versions behind.

@Robert_Holscher I actually wanted you to try 0.4.0 as that is working for me. I haven’t seen any reports of webhook bugs in the latest library or server so 0.4.3 should be ok.

Please paste as many screenshots of your project as possible and I will check with mine.

Using 0.4.2 with local server.

1 Like