[SOLVED] Virtual Pins above 40 do not work

On my project I am starting to need V pins above 40 and they seem to not work at all.
I can change to pins below 40 and they work fine.
Do I need to turn something on somewhere.

Which hardware are you using?

I am using a arduino mega and esp8266 12 E.

I was wrong. It is any virtual pin above 31.

This works:
‘’
BLYNK_WRITE(V31) { // zrtc push button
int zrtc = param.asInt();
if (zrtc == 1 ) {Serial.println(“zrtc”);Blynk.virtualWrite(V31,0);} // send zero rtc to arduino routine
}
‘’

This and anything above V31 does not. Error during compile…

Arduino: 1.6.9 (Windows 10), Board: “NodeMCU 1.0 (ESP-12E Module), 80 MHz, 115200, 4M (3M SPIFFS)”

I:\Lexar\Arduino\atmbbq_tabs_blynk\atmbbq_tabs_blynk.ino: In function ‘void BlynkWidgetWriteV32(BlynkReq&, const BlynkParam&)’:

atmbbq_tabs_blynk:117: error: ‘V32’ was not declared in this scope

      if (zrtc == 1 ) {Serial.println("zrtc");Blynk.virtualWrite(V32,0);} // send zero rtc to arduino routine

                                                                 ^

exit status 1
‘V32’ was not declared in this scope

Did you try latest blynk library from github? It should be fixed there.

That fixed it…
Thank you…
Love Blynk…

3 Likes