[SOLVED] Question about wifi mode Esp8266

used the blynk stand alone example, works great. the only thing i have a question about, is that it seems to be in client mode as well as AP mode simultaneously.

this is my code, What modifications would need to be made to be in client mode only.

/**************************************************************

  • Blynk is a platform with iOS and Android apps to control
  • Arduino, Raspberry Pi and the likes over the Internet.
  • You can easily build graphic interfaces for all your
  • projects by simply dragging and dropping widgets.
  • Blynk library is licensed under MIT license
  • This example code is in public domain.

  • This example runs directly on ESP8266 chip.
  • You need to install this for ESP8266 development:
  • https://github.com/esp8266/Arduino
  • Please be sure to select hte right ESP8266 module
  • in the Tools -> Board menu!
  • Change WiFi ssid, pass, and Blynk auth token to run :slight_smile:

**************************************************************/

#define BLYNK_PRINT Serial // Comment this out to disable prints and save space
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = “XXXXXXXX”;

void setup()
{
Serial.begin(9600);
Blynk.begin(auth, “XXXXXXXi”, “XXXXX”);
}

void loop()
{
Blynk.run();
}

What is the problem? The ESP cannot be in both modes at the same time. If it works, it works, if it doesn’t, there’s something wrong, but if you can connect to the Blynk servers it will probably be fine :slight_smile:

Try adding

WiFi.mode(WIFI_STA);

in setup() after serial.begin(9600);

I think that is where it is supposed to go. I don’t have any code to reference at the moment.