[SOLVED]Problem ESP8266 and dht11 or dht22 connection lost

Good afternoon dear,
Had a mega project and arduino ethernet shield, and decided to migrate to esp12e (node mcu), I have problems all the time reconnection Connecting to blynk-cloud.com:8442, reading saw the time it takes both DHT11 as DHT22 but found the solution, because if I only read on a timer every 3 minutes when done reading is switched off again, the wifi still connected, the ping responds me, to have cloud.blynk.cc 160ms. excuse my English, translator use.

Regards,
Mariano

¶AÁèGà,MHŒ4xx[234] Connecting to instituto_nobel
[1234] Connected to WiFi
[1234] IP: 192.168.1.238
[1235] Blynk v0.3.7 on ESP8266
TimeNTP
Starting UDP
Local port: 8888
waiting for sync
Transmit NTP Request
Receive NTP Response
[1297] Cmd skipped:20
[1594] Cmd skipped:20
[1594] Cmd skipped:20

Temperatura dht22: 22.00
Humedad dht22: 35.004
[1595] Cmd skipped:20
[2321] Cmd skipped:20
[2321] Cmd skipped:20

Temperatura dht22: 22.00
Humedad dht22: 35.002
[2322] Cmd skipped:20
[3595] Cmd skipped:20
[3596] Cmd skipped:20

Temperatura dht22: 22.00
Humedad dht22: 36.003
[3596] Cmd skipped:20
[4323] Cmd skipped:20
[4323] Cmd skipped:20

Temperatura dht22: 22.00
Humedad dht22: 36.003
[4323] Cmd skipped:20
[5001] Connecting to blynk-cloud.com:8442
[5177] <[02|00|01|00] 26bdd90623004a83bc0922440d6a240e
[5619] Cmd skipped:20
[5619] Cmd skipped:20

Temperatura dht22: nan
Humedad dht22: nan4
[5620] Cmd skipped:20
[5620] >[00|00|01|00]È
[5633] Ready (ping: 283ms).
[5663] <[11|00|11|00]Gver[00]0.3.7[00]h-beat[00]10[00]buff-in[00]256[00]dev[00]ESP8266[00]build[00]May 27 2016 14:43:48[00]
[10793] Cmd error
[10797] Login timeout
[11067] Cmd skipped:20
[11067] Cmd skipped:20

Temperatura dht22: nan
Humedad dht22: nan3
[11068] Cmd skipped:20
[11068] Connecting to blynk-cloud.com:8442
[14384] <[02|00|01|00] 26bdd90623004a83bc0922440d6a240e
[14830] Cmd skipped:20
[14831] Cmd skipped:20

Temperatura dht22: 22.00
Humedad dht22: 36.004
[14832] Cmd skipped:20
[14832] >[00|00|01|00]È
[14852] Ready (ping: 295ms).

Dear, I read the temperature and humidity every 3 minutes, it seems to be solved, so far not been disconnected.

Regards,
Mariano.-