[SOLVED] I can't get the Blynk example to run on my Spark Core no matter what I do!

I had a custom sketch running on my Spark Core (not a Photon) and it was running Blynk. For some reason, it went offline and now, no matter what I do, I can’t get anything to work.

Just to create a static test variable, I factory defaulted my Spark Core and then flashed the Spark example code.

It’s been about 2 weeks now and I can’t get it to even come online. I pull up the Serial console output window in the Arduino IDE but nothing is printed to serial UART. Before anyone asks, yes, I verified the COM port and baud rate.

Seriously, what is going on?! I had these set up to automate certain things on a schedule and now nothing is working.


EDIT: I realized that I was too pissed off and walked away before providing any insight to what exactly the problem is.

OK, first–I was running my sketch and using the Blynk API for about a week without any problems. Everything was working without a hitch. Then, all of a sudden, I noticed that my Spark Core was offline (flashing cyan rather than “breathing”).

I figured it was out of sync or maybe something was down. Shortly afterwards (within a day or so), the Spark Cloud API was having issues and I had to put troubleshooting on the back burner.

I pulled out some of my other Spark Cores that I keep for other projects and spares and I was able to claim them without any problem through Spark Cloud.

I sat down tonight with my Core and when I flash my original sketch to it, it won’t connect. I just flashes cyan until it reboots (which tells me it has valid network credentials but it isn’t talking to the Cloud). It won’t even print out anything to Serial.

I tried flashing the Spark/Particle example code (yes, I made sure that I included my token from the app and I allowed Blynk debug) and it takes the firmware and reboots but it goes right back to blinking cyan (not a fast flash but a moderate blink).

I didn’t readily see anything on the forums indicating there was an outage or a change in operations.

Seriously, can anyone help me out with this?

Hello. Please post your code. Everything is fine on our side.

@Dmitriy Thanks for getting back to me!

The Spark Cores I have were a very early iteration and sometimes the TI CC3000 gets fussy and doesn’t want to talk with the STM32F controller.

I flashed a binary during DFU that fixed the issue. I was thinking it was an issue with the Blynk authentication routine but it was an emergent issue with the hardware.

Thanks for the quick response. Blynk is an amazing suite and sure makes showing off my projects 100x easier!

1 Like

Cool. I’m very happy it is not Blynk and I’m glad you find reason by yourself :wink: