[SOLVED] Http local server - error resolving url

I am using a local blynk server and have been trying to download history graph CSV files.

When the app requests export of CSV files, the correct files are created by the server in /users//AppData/Local/Temp/blynk and the email with the correct URL is sent.

However when I click on the link the download does not occur.

The blynk log says:

21:48:08.636 INFO - GET : /Users/David/AppData/Local/Temp/blynk/my email_1_v1.csv.gz
21:48:08.651 ERROR - Error resolving url. No path found. GET : /Users/David/AppData/Local/Temp/blynk/my email_1_v1.csv.gz

I have double checked file names vs link and have tried using a different HTTP port number but that had no effect. I have tried with firewall on and off and also from within my LAN and from outside via my router which has the correct port open for the server but also no effect.

What am I missing?

Hello. Could you please show me full url you get from email?

http://192.168.0.25:8089C:\Users\David\AppData\Local\Temp\blynk\myemail_1_v1.csv.gz

I am using port 8089 at the moment as a test to see if gave a different result to using 8080.

I have tried entering the following url’s in Chrome directly but nothing happens.

http://192.168.0.25:8089\C:\Users\David\AppData\Local\Temp\blynk\myemail_1_v1.csv.gz
http://192.168.0.25:8089\Users\David\AppData\Local\Temp\blynk\myemail_1_v1.csv.gz

In the above I have just changed my actual email to myemail

You are on windows, right? Look like this win specific issue. I’ll take a look. Thank you for reporting.

Yes, the server is running on an eMachine netbook (Intel Atom) with Windows 7 starter.

By the way … the project I am running is an exercise to see how much I can get out of an ESP8266 coupled with Blynk. The test set up has the ESP8266 running an SD card on SPI, an RTC on I2C, a DSB temperature sensor on one wire and a line sensor that is counting revolutions on an induction disc electricity meter. The test is comparing the local data logging using RTC and SD card with data logging using Blynk instead. Data logging using just Blynk and ESP8266 with sensors is effective and extremely low cost - about $10 all up!

@dmorph1 could you please try https://github.com/blynkkk/blynk-server/releases/download/v0.17.2/server-0.18.0-SNAPSHOT.jar and tell me if it works for you?

Hi Dmitriy,

Works perfectly! What was the problem?

My data plotted …

Many Thanks,

David

I think I partly answered my own question … the server now provides the link as:

http://192.168.0.25:8089/myemail_1_v6.csv.gz

Windows already knows the folder location so you just need to have the file name??

@dmorph1 the problem was in my laziness. I tried to finish task as quickly as possible. So did it in most easiest way. And easiest not the best and correct. That’s what you found :wink:.

Exactly.

1 Like

:wink: