[solved] ‘error processing command server’ when I try to add the new Device Tiles Widget

hello, I ve ‘error processing command server’ when I try to add the new widget device tiles. Both my server and app are updated. Somebody else has the same thing ?

@Alx-I Hello. What server version do you have? Please sure it is latest one and you are running exactly latest one.

I Installed this one->
wget “https://github.com/blynkkk/blynk-server/releases/download/v0.28.3/server-0.28.3-java8.jar

Ok I found the problem.
The autostart with rc.local is ko since the update, but I’ve well changed it. Do you know if there something special about it?

java -jar /home/pi/server-0.28.3-java8.jar -dataFolder /home/pi/Blynk &

This command looks normal… but it does assume all of the required components are not only precisely where you are stating they are, but are where they actually need to be as well…

i.e. The server jar file is in your pi folder and not in the Blynk folder, is that the correct location for your server setup? E.g. Mine needs to be in the Blynk directory in order to work (but that could be just the way I set it up)…

java -jar /home/gunner/Blynk/server-0.28.3-java8.jar -dataFolder /home/gunner/Blynk &

The jar file is well in /home/pi
I tried with specifying the path, but no difference.
It’s strange because it was working before update… well, if nobody else has the problem…


OK, I broke this out into your own Help topic.

Lets start with the basics…

App version (actual numbers, not just “latest”)? - EDIT - Well, I guess you would have 2.16.0. since you can see the Device Tiles Widget :blush:

IOS or Android?

What, if any, error message do you see on App screen… or is the error you have described in the log files on your server?

When adding (or trying to add) the Tile Widget are you using a pre existing project or a clean new one?

I don’t know what else to ask for… this new Device Tiles Widget is strange to me… it looks like a Blynk App in the Blynk App… Blynkception :stuck_out_tongue:

Run ps -aux | grep java in your server CLI and show the output to confirm the correct server version.

Well, in fact the widget tiles is solved.
The remaining problem is that the autostart doesn’t work.
Do you prefer I open a new post?

If I launch the rc.local manually, it works->

What was the solution?

As for the autostart… if the manual command works, then simply make sure you have the same syntax perfect in your /etc/rc.local file.


Hmmm, wait… so manually running rc.local works, but a reboot will not run it?? It does take a minute or so it seems for Server to start.

I don’t know what logs to check for any rc.local errors that might occur… some Googling needed :stuck_out_tongue_winking_eye:

The widget tiles was solved while re-installing the new version of server.
For the atostart issue, it’s out of blynk subject… I’ll check on google :wink:

Thanks for the help!

1 Like