[SOLVED] Error connecting to my own local Blynk Server

Hello developers,

I have already set up my own local server, and it shows that:

C:\Blynk_Server>java -jar server-0.24.3.jar -dataFolder /Path
Blynk Server 0.24.3 successfully started.
All server output is stored in folder 'C:\Blynk_Server\.\logs' file.

which means that the local server has already been set up succesfully.

But there is something wrong when I try to connect my mobile Blynk APP to my local server,
after making sure that the APP and my commputer are in the same local network, I enter the ip address of my local server and the port number into the custom server on my app, but it always shows the message like:

You have no internet connection
I do not know whay this happens and could you please tell me how can I fix this problem?


Hello. What ip port do you use?

I use the default ip port 8443

What is default IP?

192.168.1.x is my default IP

Where are you seeing this message? Your phone or tablet?

What happened to this thread??? I am having the same problem with the same message showing on my iPhone.

Nothing happened to this thread as we never received any further info :wink:

However if, as in your case, the message is displayed on the phone then I would take it literally and check your internet accessibility of your phone via Wifi and/or cell connection.

And without further details the only other thing I can suggest is you also confirm that you are using the correct custom IP / port (pointing to your Local Server’s IP) in your Blynk App. E.g. use Local IP, if connecting over LAN, or public IP, if over WAN and have proper port forwarding setup on your router.

Perhaps even confirm that you haven’t blocked the Blynk App’s permissions to access the internet.

My WiFi connection is working fine on my cell phone for all other functions. I also tried running blynk on my android tablet with the same results. I am trying to connect to my server on a windows 10 PC with a static ip of via port 8443 on my LAN.

Any idea would be gratefully accepted.

I just want to say the thing goes well on my iPhone after several tries.

Glad to hear! :+1:

We will keep this topic going for @modicon1 as it is similar and just got started anyhow :wink:

OK, sounds like something in either your server setup or networking. Can you confirm your server has been set up for email (you will need that to get your auth tokens) and is always running in the background of your PC.

Because you are using local IP addresses you shouldn’t need to do anything in your router (though some routers might need to have internal port access unblocked as well?), but make sure that your phone and/or tablet is connected to your LAN and that the IP you are entering in your app is the same one for your PC (that is running Local Server).

Might as well also confirm you are using the latest versions of both app and server.

First of all… Thanks for the help Gunner.

I should mention that all of this was working well until I updated the iOS app on my phone to the latest version. That’s when it stopped connecting. I thought it might be that the server need to be updated for compatibility reasons, so I updated the Server to 0.24.1 and shortly after to 0.24.3. Are there any changes required to the server.properties file when that server update is done?

Yes, my server was setup for email.

There can be issues when updating the app without the corresponding server upgrade… and there was a change in certificates at 0.24.2, but I don’t think that should have affected app connection.

0.24.4 just got released… try it and report back.

I just tried 0.24.4 with the same result. Here is the Blynk log for the start-up;

14:24:08.576 INFO - Using data dir ‘\Blynk\server\data’
14:24:09.216 INFO - Region : local
14:24:09.764 INFO - Initializing gmail smtp mail transport. Username : gary@xxxxxx.ca. SMTP host : smtp.gmail.com:587
14:24:09.799 INFO - Didn’t find Let’s Encrypt certificates.
14:24:09.799 WARN - You didn’t specified ‘server.host’ or ‘contact.email’ properties in server.properties file. Automatic certificate generation is turned off. Please specify above properties for automatic certificates retrieval.
14:24:09.902 ERROR- Error initializing ssl context. Reason : File does not contain valid private key: C:\Blynk\Server\server_embedded.pem

I also tried connecting through the Blynk Server UI with the browser ( and it wouldn’t connect that way either.

1 Like

Darnit… I was looking, but was only looking in the announcements to find this… I guess my pay gets docked again :stuck_out_tongue_winking_eye:

1 Like

OK, I am now able to connect. I have to say though, it took me a lot of reading of other threads to figure out that I should run the server without certificates (I did not understand what Dmitriy was trying to say).

I already had generated certificates and was running fine with them so it didn’t make sense to me that I should now run without certs. If someone had said that the new server version will not work with old certificates and that you have to start it without certificates and re-add them later, I would have had an answer.

Anyway, problem solved. Thanks Gunner and Dmitriy for the time and effort you put into helping me… it’s still a great system.

Ah, I see now… You hadn’t clarified your initial issue. AKA already had a running functional server with generated certs and had just updated from x to y… Just that is was a “me too” issue that happened after phone App update… I thought that you were a relatively new Local Server installer :wink:

It sounds like you might have had an old version and jumped up too many versions at once? I have been running server since late last year, with my own generated certs, and haven’t had any issues updating… but I do update almost every time a new version comes out.

Anyhow, glad you are up and running again :+1:

A post was split to a new topic: I dont know which port to use