[SOLVED] Compile errors with Blynk libe v0.3.6 and Blynk Examples

The Blynk examples:

  • Arduino_WiFi_Shield_101,
  • ESP8266_Shield, and
  • ENC28j60

are three Blynk example programs I’ve tried. They each fail to compile with a .h file not found error (one example below). I’m using a fresh download/install of both Arduino 1.6.9, and Blynk library 0.3.6.
Mac OS 10.11.3, if that helps.

Typical error message:

/Users/jrobert/Documents/Arduino/libraries/Blynk/examples/Boards_Ethernet/ENC28J60/ENC28J60.ino:37:25: fatal error: UIPEthernet.h: No such file or directory
#include <UIPEthernet.h>
___________________^
compilation terminated.
exit status 1
Error compiling for board Arduino/Genuino Uno.

@vshymanskyy please have a look.

No, really. Just read the instructions in the example

Why would you need to compile such different examples? :wink:

@vshymanskyy:
“Why such different examples?”:

  • Because I have one of each.
  • Because I coach IoT hobbyists and have been steering them to who I think offer the best and most flexible IoT facilities. Collectively, they will probably use most of the inexpensive web interfaces.
  • Because I’m curious.
  • And because when one compilation failed (my personal interest is in the ESP8266) I chose to test some other, relevant examples.

“No, really. Just read the instructions in the example”:
There’s not a whole lot there. Well, besides “paste your auth code here”.

The ENC28j60 Ethernet card turns out to have been a bad example on my part. It does, in fact need a separate library that I did not load. Sorry about that.

I downloaded Blynk_v0.3.6.zip from Blynk.cc and asked the ArduinoIDE to install it as a .zip library. The IDE rejected it with “Specified folder/zip file does not contain a valid library”. (I looked in it, and it does appear to contain a valid library, but … that’s the result I got.)

Then I used the IDE’s library manager to locate the Blynk library, which it did - v0.3.6 - and installed it. I tried to compile the ESP8266_Shield example which failed with a “No such file” message for ESP8266_Lib.h. Perhaps the library manager screwed up too? I don’t know. At this point, all I’ve found out is that with a virgin install of both the IDE and the 0.3.6 library, some simple examples failed to compile.

I and my class have gone back to v0.3.4 of the library until I’m confident I can turn them (and myself) loose with a later version and expect we’ll succeed with it. I’ve I’ve screwed up somewhere, please point out where.

@JRobert the zip contains SEVERAL libraries so it can’t be installed through the IDE.

Libraries are to be installed manually as per the release notes https://github.com/blynkkk/blynk-library/releases/tag/v0.3.6

1 Like

Thanks @Costas. I tried that as a last resort a few minutes ago and discovered that. I guess I missed the memo.

Is everything OK now?

That seemed to fix it for the ESP8266 example. Sorry I missed the point about automatic installs.

Please post here if you have any problems. Thanks!