[SOLVED] Can't provision esp8266


I’m trying to provision a ESP8266 over wi-fi.

I uploaded an example sketch, ESP powers up, and when I connect to its AP, I lose data connection and Blynk app cannot connect to the server to verify device etc.

Am I too stupid for this?

ESP-01 over wi-fi
Latest Blynk IoT app on Android 9
Blynk server
Blynk Library 1.0.0 beta 3

// Fill-in information from your Blynk Template here
#define BLYNK_TEMPLATE_ID           "TMPLXxxxxx"
#define BLYNK_DEVICE_NAME           "xxx"

#define BLYNK_FIRMWARE_VERSION        "0.1.0"

#define BLYNK_PRINT Serial
//#define BLYNK_DEBUG

#define APP_DEBUG

// Uncomment your board, or configure a custom board in Settings.h

#include "BlynkEdgent.h"

void setup()


void loop() {

Ah, my bad.

I created the device in the web console, not with a phone.

I will try later on a different network.

Should be the later 1.0.0 library, or the latest files from the GitHub site.


1 Like

Thanks, but I guess the issue was that I just created device from web and it already had a predefined auth key (like in old static provision).

By the way it did not connect to my phone’s hotspot.

I realise that you marked the problem as solved, and posted your explanation, but you shouldn’t be using the old beta library, it will cause problems, and the 1.0.0 library that’s installable via the IDE is also significantly out of date.


1 Like