(SOLVED) Blynk - Arduino 101 - Bluetooth BLE - No output

Greetings,

I am having an issue getting my board to turn the LED located on pin 13 on and off. I have installed the latest Blynk drivers and uploaded the example Arduino_101_BLE code to the board. I was able to connect to the device using the Blynk app on my phone but when I create a button and set it to digital pin 13 it does not turn on and off the LED like I want it too. I tested the board with the basic blink test and the LED works but not when I am trying to send the signal via my phone. I do not understand why this isn’t working. Below is the code I uploaded to the board.

#define BLYNK_PRINT Serial

#include <BlynkSimpleCurieBLE.h>
#include <CurieBLE.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "a2f11b2c39fa4c26b48ca7c9f8ccf171";

BLEPeripheral  blePeripheral;

void setup() {
  Serial.begin(9600);
  delay(1000);

  blePeripheral.setLocalName("Blynk");
  blePeripheral.setDeviceName("Blynk");
  blePeripheral.setAppearance(384);

  Blynk.begin(blePeripheral, auth);

  blePeripheral.begin();

  Serial.println("Waiting for connections...");
}

void loop() {
  Blynk.run();
  blePeripheral.poll();
}

FYI, Bluetooth and BLE is still in Beta.

Are you using iPhone or Android?

Because the Arduino 101 is not an AVR board, there may be something else interfering with the Pin 13 LED when adding in the Blynk and/or BLE libraries.

Are you getting confirmed connection in the app (the little ship like icon beside the stop button when project running?) Do you have the BLE widget loaded in your App project and configured for the 101?

Also, with the Arduino 101 still plugged into the PC, open up the IDE monitor and see what it says there.

Sounds like you are using direct pin manipulation (i.e. no code and no virtual pins)… can you test with a different pin and LED/resistor combo? And you can also load other examples that will help show if the issue is just related to pin 13 or not.

http://examples.blynk.cc/?board=Arduino%20101&shield=Arduino%20101%20BLE&example=GettingStarted%2FGetData

Thank you for your quick response!

I was able to figure out why it was not working. Apparently my drivers in the background crashed on my computer I was using. I was a really old computer running windows 7. It was still detecting the board in the Arduino but under the device manager it developed two instances of the board so there was an issue uploaded.

I just tried it on a newer computer running windows 10 and apparently I needed to install the whole boot loader again. After I did that the program started working like a charm!

1 Like