[Solved] Blynk API sketches are failing

Hi @Dmitriy your standard API sketches (for ESP) are failing to return any values. I have used them previously and they were ok but not at the moment.

The API calls in a web browser are fine but not via the ESP and we have also tried your test tokens from http://docs.blynkapi.apiary.io/

I know you have made some changes to the API recently but we still can’t figure out why the API calls have suddenly stopped working. It might not be a recent change that has caused the problem as we have suspected we had a bug in our code for some time. Further checking indicates our bug is due to the failed API calls.

Hello. What call doesn’t work? Did you switch to latest library recently?

@Dmitriy this sketch of yours returns no values for any virtual pin we set

https://github.com/blynkkk/blynk-library/blob/master/examples/Boards_With_HTTP_API/ESP8266_ReadPin/ESP8266_ReadPin.ino

We are still on 0.3.10 and haven’t moved to 0.4.0 yet.

Do you get some error response? How exactly it doesn’t work? Do you get error code?

Web bowser for http://blynk-cloud.com/4ae3851817194e2596cf1b7103603ef8/pin/V1 returns [“1”]

Sketch returns nothing as per Serial Monitor

Connecting to MTN WIFI 19996
..
WiFi connected
Connecting to blynk-cloud.com:8080... OK
Sending GET request
Waiting response
Reading response
Done.
Read value: 

Tried changing /pin/V1 in the url to your new /get/V1, tried project etc, tried for 10 hours without any data being returned.

So simple esp sketch without any changes also doesn’t work for you?

Yes that fails and the Serial Monitor data in my last post is from your sketch, not mine.

@vshymanskyy could you please check?

Currently busy with other tasks, created issue to track this: https://github.com/blynkkk/blynk-library/issues/224

Fixed in master btanch

1 Like

Thanks @vshymanskyy I’ll check it out as soon as I can.

Confirmed as fixed.