[SOLVED] Arduino was disconnected. UNO + W5100 Shield

Hi there,

I have problem Arduino not connecting to Blynk server. When I open app on android it always said Your Arduino UNO is not in network and Arduino UNO was disconnected.

I also did portforwarding 8442 to 192.168.1.122 and reboot router many time.

I’m using Arduino UNO (Clone) and W5100 (Clone) shield. Blynk software 0.3.2.
I used example code with only change Token and Enable DEBUG

/**************************************************************
 * Blynk is a platform with iOS and Android apps to control
 * Arduino, Raspberry Pi and the likes over the Internet.
 * You can easily build graphic interfaces for all your
 * projects by simply dragging and dropping widgets.
 *
 *   Downloads, docs, tutorials: http://www.blynk.cc
 *   Blynk community:            http://community.blynk.cc
 *   Social networks:            http://www.fb.com/blynkapp
 *                               http://twitter.com/blynk_app
 *
 * Blynk library is licensed under MIT license
 * This example code is in public domain.
 *
 **************************************************************
 *
 * This example shows how to use Arduino Ethernet shield (W5100)
 * to connect your project to Blynk.
 * Feel free to apply it to any other example. It's simple!
 *
 * NOTE: Pins 10, 11, 12 and 13 are reserved for Ethernet module.
 *       DON'T use them in your sketch directly!
 *
 **************************************************************/
#define BLYNK_DEBUG
#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <SPI.h>
#include <Ethernet.h>
#include <BlynkSimpleEthernet.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "d7421bf0a9244adea9e9c3c5717d6f10";

void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth);
  // You can also specify server.
  // For more options, see BoardsAndShields/Arduino_Ethernet_Manual example
  //Blynk.begin(auth, "your_server.com", 8442);
  //Blynk.begin(auth, IPAddress(192,168,1,100), 8888);
}

void loop()
{
  Blynk.run();
}

here is Serial output

[0] Blynk v0.3.2-beta
[0] Getting IP...
[1520] My IP: 192.168.1.122
[5001] Connecting to cloud.blynk.cc:8442
[5175] <msg 2,1,32
<d7421bf0a9244adea9e9c3c5717d6f10
[5282] >msg 0,1,200
[5283] Ready (ping: 106ms).
[5284] <msg 17,1,101
<ver 
[10612] Connecting to cloud.blynk.cc:8442
[10799] <msg 2,1,32
<d7421bf0a9244adea9e9c3c5717d6f10
[10952] >msg 0,1,200
[10952] Ready (ping: 151ms).
[10953] <msg 17,2,101

The port forwarding is not needed and we can see it connect fine, but apparently it disconnects soon from what I can see (about 5s).

Have you tried using another power source? Maybe use an adapter instead of USB.

Is that latest library from trunk?

I just download a week ago directly from github master (https://github.com/blynkkk/blynk-library)

Edit: Download 0.3.1 and it’s working. No more Arduino UNO was disconnected.

1 Like