[Solved] Arduino cant connect to blynk via usb

So I’m using a arduino duemilanove trying to connect to blynk via usb. My computer is connected to wifi. My firewall is off. I have the port 8441-8443 forwarded to my computer in the router. I changed blynk-ser.bat to the appropriate com port. I uploaded the usb-serial blynk example to the arduino with my token. I ran blynk-ser.bat and cannot get the blynk app to connect. The serial monitor repeats my token followed by connection time out. I noticed that when I check ismyportopen.com is says those ports are closed and I can’t seem to get them to open. Side note : I also run wampserver on this computer and am able to get whatever wampserver port I set to open fine. Even when I set wampserver to port 8442, that port opens. Please help

I have found that the only requirements with the USB link is that the COM port and the BAUD rate need to match with the settings for the hardware and sketch’s serial settings. No port forwarding or firewall manipulation required.

Make sure you have the latest Blynk Libraries and Arduino IDE (it even has an included ‘Run USB Script’ option now).

And since you are running the duemilanove, make sure your TTL-USB adapter is wired correctly and the drivers are up to date (which if you can see your auth on the serial monitor, means that part is probably fine)… And on that note, you are not trying to run both the monitor and the script at the same time are you? - They can’t, so one or the other.

And finally… are you trying to connect to the Cloud Server, or your own Local Server?

Someone save me from this perpetual misery

@humanoidx it’s not a fix but it might help (plug and play Blynk) https://www.wemos.cc/product/d1-mini-pro.html

I’m trying to connect to the blynk cloud. Not running the scripts at the same time. What do you mean by ttl-usb adapter I’m just using a usb a to b cable for the arduino? Thanks.

Ya, sorry… was thinking about something else (and it was late :stuck_out_tongue: )

Make sure you have commented out BLYNK_PRINT e.g. // #define BLYNK_PRINT DebugSerial

As well as avoiding any Serial.print() statements.[quote=“humanoidx, post:5, topic:11220”]
Not running the scripts at the same time

You better be :slight_smile: I am referring to the USB redirection script that is required to take your USB link and redirect it through your computer to the network… thus to the server.


Run the script which is usually located in /scripts folder:
Windows:My Documents\Arduino\libraries\Blynk\scripts
Mac User$/Documents/Arduino/libraries/Blynk/scripts

Also available as a quick click option with latest library:

Ahhh! It works not that I deleted that line and am leaving the usb script running! Thank you very much Gunner! I love you.