[SOLVED] Arduino Cannot find critical Blynk Files

Using Arduino 1.6.3 (downgraded from 1.6.6 after reading post)
Downloaded Blynk zip file and imported into library menu using “import zip file”
Blynk files show up in libraries
However, when I try to run example files for Arduino Yun I get the following message:
Arduino: 1.6.3 (Windows 8.1), Board: “Arduino Uno”

In file included from Arduino_Yun.ino:24:0:

C:\Users\user\Documents\Arduino\libraries\Blynk/BlynkSimpleYun.h:18:33: fatal error: Blynk/BlynkProtocol.h: No such file or directory

#include <Blynk/BlynkProtocol.h>


compilation terminated.

Error compiling.

That file is clearly in the Blynk file structure on my PC.


Try not to import using import zip, and unpack the zip folder into C:\Users\user\Documents\Arduino\libraries\Blynk
Maybe importing is broken or something…

I tried compiling arduino_yun.ino now at 1.6.6 IDE and it worked flawlessly…

Thanks. Tried that method of unzipping and then copying files into Blynk directory of libraries and same result!

The correct file is there when I drill down to it.

It is at location:


Does that look correct?


I think that’s one “Blynk” directory too many. Try moving it up one directory.

No, its correct. He means that the “missing” file is in that directory. I’ve got the same and it works:

The structure should look like this:

Pavel - That worked!