[Solve] Bug in Widgets settings on blynkApp using local server?

I always set the frequency in “Push” as shown in Fig.1


Fig.1

and when i log out from my project or restart my local server.
The frequency always automatically change to “1 sec” as shown in Fig.2


Fig.2

It’s my problem! my project use less than 1 second frequency around 4 Hz, So, I should change the setting
in many widgets before running the project. Can it fix? This is not critical ! but If it possible to fix, it would be better.
Thank you!

What interval is your hardware’s timer set to push the data to the server?

(250 ms) @Jamin

Is that iOS?

No in your code… what is your SimerTimer set to?

Yes, it’s iOS. @Dmitriy

Is that latest server and latest app version?

blynk lnc version 2.5.6 (iOS), I think it’s the latest app version.
and the server is around 0.18.4. updated for a month @Dmitriy

timer.setInterval(250L, sensor);  
timer.setInterval(5000L, sent2); 

and this is my timersetinterval @Jamin

Thank you! all

So this bug is for graph widget only or for all?

Please do next :

  1. Add widget;
  2. Change to push;
  3. Run project;
  4. Stop project;
  5. Open settings is there still push?

It’s also happen on Value Display and Gauge that i used.

and i did 1-5 , in the end it’s still Push @Dmitriy

sorry @Dmitriy The answer that i told you it’s still push, I was tested only few second!
but when i tested my project about 2-3 minute, It automatically change to 1sec again.

Thank you. We will try to fix it ASAP.

@Dmitriy i found some bug now!
when i add BLT(beta) to the project the problem will happen, Then when i remove it,
It not convert to 1 sec again, Thank you

Oh… This is expected for BLE. It was implemented in that way. @Pavel do you remember why?