BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

"SmartLED Controller" - ESP+FastLED+Blynk (Video)

Am thinking of putting 2 strips in series and make first 8 led’s colour 1 and second 8 led’s colour 2. I only have to use 1 pin in that case.

very nice project @Jamin, i’ve currentl just rigged up 7 ws2812’s to an ESP-01 changed settings to GPIO2 and LED NUM to 7, power only 3.3v and it works like a charm. i was using a wemos D1 R1 old board, then a wemos D1mini and just to see the ESP-01.
just one question, i’m using the arduinoOTA anyway, just a bit confused about how to use the lounge / office setup in settings, can you explain just that portion please?

Great project thanks! I’m struggling to making it work tho. I think I might be doing something wrong with the Blynk app, I couldn’t scan your project because I don’t have that much “energy” that is why I wanted to add the modules I could afford with the free app. For instance I added a push button, assigned it to pin v6 (behavior 0-1), according to the code that might turn all LEDs red, but nothing happens. Am I wrong?

PS. I’ve tried with neopixel library with an esp8266 server for triggering it and it worked, so I might not have the schematics and PIN numbers wrong. I think the only thing wrong is the Blynk app logic I’m using.

Waiting for your response,
Thanks!

EDIT: after some debugging and trying with other projects that use FASTLED library, I came to the conclusion that it is its fault. With NeoPixel library I have no problem at all, but with the FASTLED I’m not getting any response. Perhaps it has to be something with the initial error I get when compiling:

    In file included from /Users/user1/Documents/Arduino/ESP8266-WS28xx-Blynk/ESP8266-WS28xx-Blynk.ino:5:0:
    /Users/user1/Documents/Arduino/libraries/FastLED-3.1.8/FastLED.h:17:21: note: #pragma message: FastLED version 3.001.008
     #    pragma message "FastLED version 3.001.008"
                         ^
    In file included from /Users/user1/Documents/Arduino/libraries/FastLED-3.1.8/FastLED.h:68:0,
                     from /Users/user1/Documents/Arduino/ESP8266-WS28xx-Blynk/ESP8266-WS28xx-Blynk.ino:5:
    /Users/user1/Documents/Arduino/libraries/FastLED-3.1.8/fastspi.h:110:23: note: #pragma message: No hardware SPI pins defined.  All SPI access will default to bitbanged output
     #      pragma message "No hardware SPI pins defined.  All SPI access will default to bitbanged output"
                           ^

Hi,

I’m having an issue getting this code to work. I have a WS2812B LED strip and a Wemos D1 Mini. I’ve got the strip working with example code from the FastLED library. I got the BlynkBlink example working through wifi to light the built in LED on the Wemos.

I’ve followed the Readme.md file from the github link. When I upload the sketch it seems to be having an issue with the wifi connection. In the app it says “Wemos D1 Mini wasn’t online yet”. In the Arduino IDE serial monitor I get strange characters like this “⸮ࠆ⸮⸮⸮Ȯ⸮⸮v⸮⸮)
^⸮⸮c⸮⸮⸮V$”

Anyone know what I’m missing?

These strange characters in the serial monitor are because the baud rate of the serial monitor doesn’t match the baud rate of the Wemos.

The Wemos uses a default baud rate of 74880, so all boot messages are displayed at this rate. Once the device has booted and started running the code the baud rate will change to whatever is specified in the code.

I prefer to use the 74880 baud rate for my debug messages, so that the serial monitor will correctly display both the Wemos system messages and the debug messages from within the code.

Pete.

1 Like

I changed the baud rate in Serial Monitor to 74880 but still funny characters. 115200 works though. It says …

[1308822] Connecting to 192.168.1.2
[1313823] Connecting to 192.168.1.2
[1318824] Connecting to 192.168.1.2
[1323825] Connecting to 192.168.1.2

Adds a new line every few seconds.

That’s because you’ve not edited the settings.h file. By default, it’s trying to connect to a Blynk local server at 192.168.1.2

Pete.

1 Like

I hadn’t commented out the Local server settings in the settings.h file. I did that and it seems to be working fine :smiley: Thank you Jamin and everyone for all the code and info

First of all, thank you very much for this code.
Im using this for my living room ceiling light and it doesnt only look amazing, its easy to use too!
But i have one small problem…
Depending on the set value on “updates per sec”, the esp happens to “reset” itself after a few minutes (sooner or later, depending on the value set earlier).
Im guessing there is just a timer or delay function resetting the preset/loop after a given time?
Is it possible to bypass or strech that time? Because i want to replace my original ceiling light with my new WS2811 LEDs. But if its resetting itself, its just odd.

I hope that you didnt have too many problems reading this lol.

regards!

I’m getting this error with arduino OTA(latest version), what can i do?

Sketch uses 292788 bytes (58%) of program storage space. Maximum is 499696 bytes.
Global variables use 32312 bytes (39%) of dynamic memory, leaving 49608 bytes for local variables. Maximum is 81920 bytes.
error: Failed to open COM15
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

Make sure COM15 is available :stuck_out_tongue_winking_eye: AKA, the correct COM port on your PC to program your ESP, and not used by something else.

Hmmm… OTA doesn’t use a COM port, it uses an IP port… are you doing your flash correctly?

I am having the same problem, What exactly did you comment out?

The same problem as what?

Pete.

@Rel0aded Looks like a clear statement to me… if you don’t understand how to work with separate .h files in the IDE, or the difference in Local Server vs Cloud Server settings, then this might be more complicated then you need for a starter? project.

basically which line should I comment out?

The issue I am facing is that my device is not showing up online and when I connect to the serial monitor it constantly displays prints to ip

If you are wanting to use the Cloud Server, then you could read the directions right above that referenced group of commands for that answer :stuck_out_tongue_winking_eye: (Hint they are already in a group)

InkedComment_LI

Hello, I liked the project and I wanted to screw it out. Unfortunately I can not read the qr code. The application does not recognize it. I tried to the “REMOTE SWITCHES” and he loaded it. I am asking for help in solving the problem.

This is a very old topic and I haven’t seen the OP around lately… but I just tested the GitHub QR and it still works fine…

1 Like

A post was split to a new topic: Wanted to use the Menu widget instead of just go to the next patern with pushing the preset button