Slider widget still jumping to zero

@Gunner I have tried what you suggested and it didn’t fix the issue.

In doing some more testing, replicating the issue is super simple.

  1. Create a new project
  2. Place one slider on the project and connect to V0 (doesn’t have to be V0)
  3. Run the project (doesn’t matter there is no hardware connected)
  4. Leave Blynk running, lock your screen
  5. Unlock your screen
  6. Move the slider…voila! Jumps to zero every time
    To fix the issue
  7. Click on the top left button, select your project again
  8. Move the slider… …now it works.

@ldb Yes the output is a relay, why do you ask?

@DrDigital, I tried to reproduce your issue on my two Android devices, on cloud server, as well as on the local one. And I failed! I mean, if there is any virtual pin assigned, then it restores the value correctly. It jumps to “0” only if the pin is NOT assigned, which is obvious - no source to sync with. At this point I have no idea what is the problem in your case…

@DrDigital I agree with @marvin7 I also can not reproduce the issue. None of my projects, new or old, have any issues with any sliders. I suspect your issue is localised, which is why i had suggested the full project removal, reset. Perhaps you need to do that same with the App.

Do you have another device to test on… even an emulator like MeMu or NOX will let you know if the issue is just on your phone or in your projects.

Also… are you using a Local Server or the Cloud server?

This is bizarre then. I can cause it to happen 100% of the time and I can work around it 100% of the time. There has to be something with my app or phone causing it. I will try a different android device and will also try deleting the app, removing all data associated and try again.

@Gunner the issue for me exists on all projects even if there is no hardware connected and I am using the Cloud server. It is definitely a bug but must be related to something on my phone that we haven’t homed in on yet.

There was a bug, I agree… but it has long been cleared that I am aware of… which is why I suspect you might still have some residual issues in older or overlayed App, Library or Local Server, if you use it.

It is a pain, but sometime the total Re & Re is the only way to clear residual “bugs”.

Relay is not fast enough to respond to PID effectively, and its life is very short if you cycle it a lot.

I’d recommend using a SSR with analogueWrite

Ok. I uninstalled the app, ckeared the data, reinstalled, re created the projects and guess what?

Still doesn’t work…sigh

That’s not good :frowning:
You can check, what is the last value stored on server just after putting into sleep the Android device. You can do it through http app API, but the exact syntax you need to check- it’s been changed some time ago. This won’t help the issue, but will give you an answer if the improper value is stored or it is “just” the application issue.

I am still seeing the slider jump to zero bug even with Android app 2.23.1 both on local server and cloud server with a device connected or not. I will try to create a video for this as i cant believe I am the only one seeing this.