BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Several Blynk 2.0 issues

I am having several issues with Blynk 2.0. Maybe someone can point me in the right direction. First, let me say that my firmware worked just fine in the legacy app. I am connected to my device with 2.0 and have the template information and correct auth token.

First, I have a Pro plan. In that plan it states that support is available via email 1-3 business days. Who do I email? I cannot locate that information.

I created a template during the free trial. Using that template I have the following issues;

Map widget-although I can see in the serial data that my button pushes are working correctly and providing GPS data, nothing happens with the map. Out of desperation, I deleted the map widget from both my template and my app. Now that I have done that, I can no longer add the map widget back to my app-says :“not available”

I have a VLED assigned to the cellular radio on my device. It is supposed to update when the radio is either ON or OFF. Yesterday, when I shut the radio off the VLED updated to OFF but now refuses to update to ON. The radio is ON and I can carry out other functions so I know I am connected and this is verified also in my data log. I have deleted and added the LED widget numerous times as well as flashed the firmware several times in hopes that the situation resolved itself, it has not.

In the device/dashboard I can see switch widgets updating when I toggle them in the app. However, now I have one switch that although it works in the app, it no longer updates in the dashboard.

I am tempted to just delete the entire template and just start over, I thought I would start here first.

Thanks in advance

Hello. Most of the issues were fixes with the recent deployment. Could you please let me know if you still see some problems?

@Dmitriy

Located

By updating the mobile app, I was able to load the map widget. However, although my code worked flawlessly in the legacy app, I am still not able to make it function with Blynk 2.0

This is now working. By deleting it and adding it back several times, it finally started working correctly

This was a V0 issue and yes, it now works correctly.

I also have an issue with the slider. My values are set to 5 and 15 on the web dashboard. When I am on the Device Dashboard those values are retained only so long as I do not navigate away from that page. If I do, the value changes to 1-15. Further, if I move the slider widget on the mobile app the result is the same as the navigation error noted above. Pavel is aware of this issue and has screen captures etc. I do not know where he is at with it as I have not heard from him since the 5th. But he informed me then that it will be fixed soon as possible.

So, my outstanding issues are with the map and slider. I also sent you a DM related to a previous issue. Not sure if you ever saw it?

Thanks very much for your reply. I know you guys are busy :sweat_smile:

We’ll improve this part as well soon.

iOS app, right? Did you assign Location Data Stream to the map widget? Could you please show minimal code send updates the map widget?

Could you please clarify where the value changes? On the mobile app slider or web slider?

Also, when you say 5-15 do you mean DS settings? Or widget settings?

Noted, thank you

iOS, correct. Yes, data stream is assigned. I have emailed you screen shots, code and video which should also help explain your last question. Let me know if you need more information and thank you very much

@mpo881 Hi, can you provide data stream settings please?

Data stream for slider was incorrectly set at 0-1. Changing to the required settings of 5-15 and saving them, solved the slider issue. A simple solution and one I completely missed. I am sure the map widget will end up the same way :grimacing:
Thank you

1 Like

You’re welcome. :+1:

1 Like

@Dmitriy_Bazhenov @Dmitriy
Any update on the map widget issue please? Thank you

@mpo881 which map widget do you have problem with? Web map or mobile app map?

Both. Neither are working. I have emailed you code and screen shots. Let me know if I need to send additional information.
Thank you

@Dmitriy ping. Any update on this? I am nearing launch.
Thanks

Hello. This one is not yet done. We need to finish few other things firrst.

Thanks for the reply. Any estimate on the timeline please?

@Dmitriy ping. Any update here on the timeline please? Thank you

@mpo881 hello, no timeline for this one.

Well that is certainly bad news. So, is the map widget not working at all?

@mpo881 It should work. You said you sent logs + video, but I can’t find it. Could you please forward again to dmitriy@blynk.cc

@Dmitriy I have just emailed it. Please advise if you received.
Thank you

Hello, could you please send logs and video to hanna@blynk.cc?