Server, sometimes it connects, other times it doesn't

I am having trouble with my project connecting to blynk. I am using an ESP01, and it seems to always connect to the router, but when it comes to connecting to the server; sometimes it connects right away, other times (more often than not) it does not connect at all. What seems to help is updating the “auth code” until it works, but this I am not sure about.
I have not been able to find any any issues where connection to the server is intermittent like this.

Hardware:
Arduino Leonardo
ESP01- w/ separate 3.3v power supply
RHT03

DEBUG:
[5737] Cmd not sent
[5737] Cmd not sent

Any help would be appreciated. I can’t tell you how much I enjoy working on with the Blynk App, it really opens up a lot of opportunities.

Thanks!

#define BLYNK_DEBUG
#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266_HardSer.h>
#include <BlynkSimpleShieldEsp8266_HardSer.h>
#include "DHT.h" 
#include <OneWire.h>
#include <SimpleTimer.h>
DHT dht;  
SimpleTimer timer;
#define EspSerial Serial1

ESP8266 wifi(EspSerial);

float temp;
float humid;



// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "e722a6527a554a89bd74608a8ff5b8c2";

void setup()
{
  timer.setInterval(1500L, sendUptime);
  pinMode(13, OUTPUT);
  dht.setup(4);
  Serial.begin(9600);
  delay(10);
  // Set ESP8266 baud rate
  EspSerial.begin(115200);
  delay(10);
  Blynk.begin(auth, wifi, "Network", "password");  //, "cloud.blynk.cc", 8442); tried this as well as updating the library
  delay(10);
}

void loop(){
  Blynk.run();
  timer.run();
  
  
  if(Blynk.connected()) {
   digitalWrite(13, HIGH);}
   else{
   digitalWrite(13, LOW);}
    
   
}


void humiditychk(){
  delay(dht.getMinimumSamplingPeriod());
  humid= dht.getHumidity();
  temp=dht.toFahrenheit(dht.getTemperature());}


void sendUptime(){
 humiditychk(); 
  Blynk.virtualWrite(V2, temp);
  Blynk.virtualWrite(V3, humid);
Serial.println(humid);
Serial.println(temp);}

I have same problem too…

Have you guys put a little capacitor across the power supply before the ESP? In my case that solved a lot of stuff.

It could also be a matter of bad Wifi signal, especially in more urban neighborhoods, since the ESP only supports 2.4 Ghz it’s prone to interference.

Lichtsignaal,

I currently have a 100uF capacitor across the power supply before the ESP. Would you suggest a different value?

I have restarted the router multiple times, but I live in a fairly rural area and I only pick up my router when searching for networks on all devices.

That should be fine then. I use whatever caps I can find in old alarm clocks … LOL.

I would suggest to try and set up a local server to exclude problems with the cloudservice like latency or some things like that. You can run the Java software on your PC for testing purpose.

So, I got to investigating the problem I have been having with the ESP-01 and determined it was not a code issue, but rather the size of the capacitor. With the 100uF capacitor connect to the power supply By trial and error I put a 1000uF cap. in and it seemed to have done the trick.

Previously I found that every time the ESP-01 powered off, it would work after the firmware was re-flashed (why I don’t know.) What is the reason for the?

put in parallel a very smaller to cut very high frequency noise ex. 100nF. Big capacitors does not help much in very high frequencies tho

Report back if you see any improvement please