BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

RFDuino BLE

There is an example for RFDuino BLE in the master branch.
But I have no hardware to test it with…
Could someone check if it works for you?

I’ll take a look right now

I have the .ino file up and it looks like I need to go to the blynk app and drop a Bluetooth widget on there but what do I select as the board? I don’t even see simblee in the list of options, or I would have tried that.

Looking at http://docs.blynk.cc/#getting-started-getting-started-with-hardware-how-to-use-an-example-sketch
I should just be able to run it and get this in the terminal

Upload the sketch to the board and open Serial Terminal. Wait until you see something like this:
Blynk v.X.X.X
Your IP is 192.168.0.11
Connecting…
Blynk connected!

Can’t get it online. I think it is supposed to connect through my phone, right? The setting for the Bluetooth button says connect BLE device but the selection list is empty.

As a workaround to get connected, I opened and ran my blynk app but then opened my RFduino colorwheel app.
I got connected by opening the colorwheel app, which opened the Bluetooth connection to the RFduino device. Unfortunately, I still can’t get it to communicate through the Blynk app. It just says login timeout. When I close the colorwheel app, it says device disconnected.

Waiting for connections…
[12554] Device connected
[14555] Login timeout
[19556] Login timeout

[92054] Device disconnected
[92054] Disconnected

and yes, my blynk app has the Bluetooth icon in it (and a terminal in it) but, again the list is empty.
I need to know what to set the

  1. hardware model in the project settings and …

  2. what to do with the connect BLE device button with an empty list

Thanks, I thinks our Apps are not detecting it yet… we’ll have to wait for the next release.
I’ll ping back you when it is ready…

1 Like

Ok. Thanks. Let me know of any additional testing you need. If need be, I can mail you an RFduino. I have a few.

I see that the simblee has been added would this also put in place the necessary construct for the Rfduino? They are similar in many ways but I am unsure if they are similar enough.

Could you try with the latest app from the Google Play - does it show your Rfduino?

I’ve tried with the latest Android app and the RFduino poped up on the list.

@Avenue33: How do you manage this? I’ve installed 1.15.3 and RFduino is not showing up - only the simblee.

I’m using the example Blynk > Boards_BLE > RFDuino_BLE on Arduino IDE 1.6.11 with RFDuino boards 2.3.1.

The tablet is an Acer B1-770 with Blynk 1.15.3 running on Android 5.0.1.

[19] Blynk v0.3.9 on Arduino
Waiting for connections…
[256[19] Blynk v0.3.9 on Arduino
Waiting for connections…
[18656] Device connected
[20657] Login timeout
[23807] Ready (ping: 150ms).

Bluetooth enumeration is sometimes tricky. Try and switch Bluetooth off and on. But it doesn’t work with LightBlue Bean.

We did LightBlue Bean. However it is very unstable for unknown reason. So it is not yet released.

1 Like

@Avenue33: Sorry I misunderstood your post. I thought you refer to the list of available boards. I am working with the RFduino for a while and it is really stable. I tried the Arduino 101 first, but they have serious problems and so I switched to the RFduino - a platform I used in my physics-lab before for wireless temperature measurements :wink:

Now I made a small CAN Bus shield to show the data of my car on Blynk:

Nice!

Sorry, I didn’t mention that, when I created the project, I took the Generic board, as the RFDuino wasn’t listed.

Digging up an old post but I’ve still got these sitting around. So, is rfduino supported of not really? Do I have to select “generic” and it will work anyway?

Yes, you can select generic