Request API and invalid Token (one more... sorry)

Hello,
I saw that other users had same problem , but i can’t solve it…
I use an esp32 with micropython ant the new Blynk application on android
I just want tu update datastream value with a simple API request. I did it with the old application but i’m not successful with the new one.
I follow instructions from here( Update Datastream Value - Blynk Documentation)
and here( HTTPS API Troubleshooting - Blynk Documentation)
My blynk server is : lon1.blynk.cloud (ip : 159.65.55.83)

Now the code i use:

import urequests
url = "http://159.65.55.83/external/api/update?token={my token}&v0=234"
response = urequests.get(url)
print(response.text) 
print("statut code:  " + str(reponse.status_code))

And the answer is always the same :
{“error”:{“message”:“Invalid token.”}}
statut code: 400

I also tried with https and http request on a web browser with same result.
I hope someone will help me.
Thanks.
G.B

Hey there,
Your url should look like this sample

https://blynk.cloud/external/api/update?token=ffujYGgbf805tgsf&v1=100

Just replace the auth token and the pin number.
Also read this
https://docs.blynk.io/en/blynk.cloud/troubleshooting

Thanks for your answer.
Same result with your url.
And i wrote : My blynk server is : lon1.blynk.cloud (ip : 159.65.55.83) so i follow this instructions (HTTPS API Troubleshooting - Blynk Documentation)…
The problem is somewhere else…

This is just a sample, it’s not my url.
As I mentioned, just change the auth token and the pin number as you wish and leave everything as it is.
Don’t replace blynk.cloud with the server IP.

I’m ok with you. That’s what i did with:
url = “https://blynk.cloud/external/api/update?token={mytoken}&v0=100
same result

Are you using { } in the url ?

of course not

What about the " ?

I use it with strings and python but i don’t paste it in web browser.

Okay, use it in the web browser, just to make sure it’s working fine.

I did it one more time in the web browser… same result ({“error”:{“message”:“Invalid token.”}})

It would be useful if you could post the EXACT url you are using, you can generate a new Auth token later.

Pete.