BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Report widget doesn't work

Hello,
if I insert the report widget in my project, I am not able to insert the datastream…
I have a local server running on a raspberry…
This is what I see:

How can I solve?

Thanks for the support

Have you enabled Raw Data Storage on your local server and is it working?

Pete.

Thanks for your reply, honestly I don’t know.
Could you suggest a link that explains how to do?

I think you’d remember If you’d done it, as it’s quite involved…

Pete.

OK, I’ve done just now…
This is the postgres.log:
20:19:07.366 - DB url : jdbc:postgresql://localhost:5432/blynk?tcpKeepAlive=true&socketTimeout=150
20:19:07.366 - DB user : test
20:19:07.370 - Connecting to DB…
20:19:20.186 - Connected to database successfully.
20:19:20.196 - Reporting DB url : jdbc:postgresql://localhost:5432/blynk_reporting?tcpKeepAlive=true&socketTimeout=150
20:19:20.197 - Reporting DB user : test
20:19:20.198 - Connecting to reporting DB…
20:19:20.563 - Connected to reporting database successfully.
20:20:00.046 - Storing MINUTE reporting…
20:20:00.073 - Removing old reporting records…
20:20:00.128 - Removing finished. Minute records 0, hour records 0. Time 79
20:20:00.130 - Storing MINUTE reporting finished. Time 85. Records saved 4
20:21:00.016 - Storing MINUTE reporting…
20:21:00.026 - Storing raw reporting…
20:21:00.042 - Storing MINUTE reporting finished. Time 27. Records saved 3
20:21:00.043 - Removing old reporting records…
20:21:00.057 - Removing finished. Minute records 0, hour records 0. Time 28
20:21:00.086 - Storing raw reporting finished. Time 60. Records saved 15
20:21:01.441 - Storing users…
20:21:01.656 - Storing users finished. Time 215. Users saved 1

It seems to work but the report widget doesn’t change. I also done a logout and login in the app and remove and insert again the widget…

Okay, try adding a superchart widget and see if the datastreams that you want are available. If the are then see if that changes your report widget.
If not then maybe restart your Blynk server?

Pete,

Nothing, I also just updated to the last version 0.41.12 but nothing changes…
But the widget should let choose the datastream in edit mode, right?

Yes, it should.
What type of device and connection method do you have in your app project?

Pete.

I’m using an arduino mega with lan connection (ENC28J60)

So your app settings for that device say “Arduino Mega” and “Ethernet” ?

Pete.

yes

I see that with another project connected to the same server works. In this case I have an arduino mega with ESP8266… So I think that isn’t a server problem…

And can you see both devices in your server admin panel when you click your username and scroll down?

Pete.

Yes I see both

Maybe one for @BlynkAndroidDev then?

@Erik_Castelli can you provide information about the app version and local server version please.

Pete.

Blynk app version 2.27.14, blynk local server 0.41.12.

Many thanks

How does your dashboard looks? Do you have any device or device tiles in your project?

You probably have an empty device tiles widget (without any templates). If there is a device tiles widget in the project - reports widget will allow to create data-streams only from it’s templates. I will add a check for an empty device tiles widget.

Yes!!! I have an empty widget. Removed and it WORKS… Great!
Thanks to eveyone

2 Likes