BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Report generates an error

android

#1

-app: 2:25:0
-server: server-0.37.2-java8.jar
-mail server works
-Samsung galaxy S8 edge

I thought to try out the new ‘report’ widget and noticed a couple of things:

  1. I’ve taken one value (tried several) and generated a report. This resulted in an error ‘failed to generate, check settings or try later’.
  2. I noticed that if I use e.g. V10 for three widgets (value display and 2 graphs) it shows up 3 times in the ‘choose datastream’ section. Perhaps this is intentional, but its a bit confusing at first. Granted given the fact that I use 3 different labels (‘huidige temperatuur’, ‘temp’ and ‘current’) for the same V10 its a bit hard to decide which to pick.

(and as has been reported numerously by now: changing the font size is not really appreciated. They’re way to small and even setting it to large its still too small. )


#2

Please post here your blynk.log file.


#3

obviously there’s a log…:roll_eyes:

I had a look and here are the last entries. What I don’t get is: I just tried it around 10:00(am) the time on the server is correct, but the log entries (assumming they’re times) are 16:16 so thats at least yesterday.
edit: now the last modification is: 13/05/2018 : 16:16. So this is an ancient log. I’m apparently looking in the wrong place?
“/home/pi/blynk/logs”

16:16:03.462 INFO - Using data dir ‘/home/pi/blynk’
16:16:07.107 INFO - Region : local. Host : 192.168.1.93.
16:16:10.067 INFO - Initializing gmail smtp mail transport. Username : rsegers@gmail.com. SMTP host : smtp.gmail.com:587
16:16:10.213 INFO - Didn’t find custom user certificates.
16:16:10.221 INFO - Didn’t find Let’s Encrypt certificates.
16:16:10.221 WARN - You didn’t specified ‘server.host’ or ‘contact.email’ properties in server.properties file. Automatic certificate generation is turned off. Please specify above properties for automatic certificates retrieval.
16:16:10.222 WARN - ATTENTION. Server certificate paths (cert : ‘/home/pi/blynk’, key : ‘/home/pi/blynk’) not valid. Using embedded server certs and one way ssl. This is not secure. Please replace it with your own certs.
16:16:15.137 INFO - Hardware SSL server listening at 8441 port.
16:16:15.146 INFO - HTTP API and WebSockets server listening at 8080 port.
16:16:15.150 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
16:16:15.154 INFO - Mqtt hardware server listening at 8440 port.
16:16:16.256 INFO - rsegers@gmail.com hardware joined.
16:16:16.397 INFO - rsegers@gmail.com hardware joined.
16:16:16.864 INFO - rsegers@gmail.com hardware joined.
16:16:17.377 INFO - rsegers@gmail.com hardware joined.
16:16:17.392 INFO - rsegers@gmail.com hardware joined.
16:16:17.769 INFO - rsegers@gmail.com hardware joined.
16:16:17.961 INFO - rsegers@gmail.com hardware joined.
16:16:18.365 INFO - rsegers@gmail.com hardware joined.
16:16:19.269 INFO - rsegers@gmail.com hardware joined.
16:16:19.802 INFO - rsegers@gmail.com hardware joined.
16:16:19.826 INFO - rsegers@gmail.com hardware joined.
16:16:21.344 INFO - rsegers@gmail.com hardware joined.
16:16:21.415 INFO - rsegers@gmail.com hardware joined.
16:16:21.883 INFO - rsegers@gmail.com hardware joined.
16:16:22.395 INFO - rsegers@gmail.com hardware joined.
16:16:22.406 INFO - rsegers@gmail.com hardware joined.
16:16:22.781 INFO - rsegers@gmail.com hardware joined.
16:16:23.382 INFO - rsegers@gmail.com hardware joined.
16:16:24.284 INFO - rsegers@gmail.com hardware joined.
16:16:24.818 INFO - rsegers@gmail.com hardware joined.


#4

Probably ancient, yes.


#5

so where’s the ‘current’ log file?


#6

You tell me. It is usually in the same folder from which you run the jar file.


#7

found it, it was under home/pi/logs (a bit unexpected)

09:29:29.202 INFO - rsegers@gmail.com hardware joined.
09:29:35.799 INFO - rsegers@gmail.com hardware joined.
09:29:49.724 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.
09:31:36.648 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.
09:34:50.332 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.
09:37:00.939 ERROR- Error compressing report file.
09:37:00.952 ERROR- Error generating report 63253 for user rsegers@gmail.com.
09:37:00.952 ERROR- java.util.zip.ZipException: duplicate entry: 1651190328_23553_v12.csv
09:37:00.952 INFO - Processed report for rsegers@gmail.com, time 964 ms.
09:41:06.365 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.
09:42:56.877 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.
09:46:40.423 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.
09:48:25.046 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.
09:48:47.783 ERROR- Error compressing report file.
09:48:47.795 ERROR- Error generating report 63253 for user rsegers@gmail.com.
09:48:47.795 ERROR- java.util.zip.ZipException: duplicate entry: 1651190328_23553_v12.csv
09:48:47.795 INFO - Processed report for rsegers@gmail.com, time 287 ms.
09:51:17.522 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.
09:51:20.762 ERROR- Error compressing report file.
09:51:20.773 ERROR- Error generating report 63253 for user rsegers@gmail.com.
09:51:20.773 ERROR- java.util.zip.ZipException: duplicate entry: 1651190328_23553_v12.csv
09:51:20.773 INFO - Processed report for rsegers@gmail.com, time 313 ms.
11:35:08.407 INFO - rsegers@gmail.com Blynk-app (android-22500) joined.


#8

I see. Thanks I’ll check what that could be.


#9

@wolph42 could you please post here your report settings? (sources and devices screen)


#10

@wolph42 ok. no need, seems the issue is due to " it shows up 3 times in the ‘choose datastream’ section"


#11

ok. Anything I should/can do or will there be a fix later on?


#12

ok. Anything I should/can do or will there be a fix later on?

You can remove duplicated data streams. This should help.


#13

you mean from the device tiles? In that case ill wait for the fix, I require the 3 ‘interpretations’.

I would imagine that more people would have this issue, basically Im using (e.g.) V10 to show active value in value display and V10 in a graph to see the history (a third one I use for checking heating response times). Its fairly basic use.


#14

From the report configuration.


#15

i did that initially. I’ve only selected 1 datastream and that generated this error (selecting more streams generates the same error).


#16

This issue with several same streams is already fixed in 2.25.1 build


#17

you people are fast!! Anyway, I still get an error on send…


#18

Hm, had you removed already saved duplicate streams from reporting widget settings? Or just remove reporting widget and add a new one


#19

no, but I have now (removed report, created a new one, selected one stream), same issue: failed report


#20

Report or Reporting Widget?