BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Rele encendido en el inicio y tras un reset

Estoy probando blynk con un ESP8266 WIFI y un teléfono Adroid,

El Nodecmu ESP8266 lo conecto a un rele.

El problema surge cuando iniciamos que automáticamente enciende el relé, también cuando un reset en el nodecmu, hasta que pulsamos en el teléfono no cambia correctamente.

He probado vario ejemplos y a todos les pasa lo mismo.

Alguien me puede ayudar.

Gracias.

Check this example https://examples.blynk.cc/?board=ESP8266&shield=ESP8266%20WiFi&example=More%2FSync%2FHardwareSyncStateFromApp

1 Like

Gracias por el aporte.
también lo he solucionado así:
void setup()
{
// Debug console
pinMode(D6, OUTPUT);
pinMode(D0, OUTPUT);
digitalWrite(D0,HIGH);
digitalWrite(D6,HIGH);
Serial.begin(115200);

Blynk.begin(auth, ssid, pass);
// You can also specify server:
//Blynk.begin(auth, ssid, pass, “blynk-cloud.com”, 80);
//Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);
}

void loop()
{
Blynk.run();
}

Hola a todos,

Tengo el mismo problema que quien puso el mensaje inicial, pero el caso es que yo tengo la declaración tal como la hace él y me pasa lo mismo, no logro solucionarlo.

Cuando arranca el ESP los dos relés se me conectan y no se por que.
Por favor, alguna ayuda…
Mi código https://pastebin.com/s16pM2Cp

@Ash2 it’s never a good idea to post about the same issue in two different topics. You risk getting responses in two different places, which can quickly get very messy when you’re trying to implement suggestions that have been made.

I’m going to lock this topic. If anyone has suggestions for @Ash2 about this issue please make them in this topic:

Relay on after start

Pete.