RedBear Duo question

Hello all,

I just got the RedBear Duo board, the little thing looks promising, no as ease or mature as the ESP8266, but it works.

Somehow I got the WiFI Blynk example working, but I cannot get the Blynk.virtualWrite going, I get an error saying the virtual pin I am trying to use is not declare: ā€˜V35ā€™ was not declared in this scope

I am using the latest Blynk 0.4.3
Here is the example I am using:

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <BlynkSimpleRedBear_Duo.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

int x = 10;

// Your WiFi credentials.
// Choose wifi_sec from WPA2, WPA, or WEP
char ssid[] = "YourNetworkName";
char pass[] = "YourPassword";
int wifi_sec = WPA2;

//SYSTEM_MODE(AUTOMATIC);
SYSTEM_MODE(MANUAL);

void setup()
{
  Serial.begin(9600);

  delay(5000);

  WiFi.on();
  WiFi.setCredentials(ssid, pass, wifi_sec);
  WiFi.connect();

  Blynk.begin(auth);
  // Or specify server using one of those commands:
  //Blynk.begin(auth, "blynk-cloud.com", 8442);
  //Blynk.begin(auth, server_ip, port);
Blynk.virtualWrite(V35, x); /* <== this is not working */
}

void loop()
{
  Blynk.run();
}

Guys, gals,

Never mind, taking the ā€œVā€ away solved the problem. I am so used to the ESP8266, I always use the Blynk.virtualWrite with the ā€œVā€

@italex33 you probably need to enable this feature :

#define BLYNK_USE_128_VPINS

AS by default we have 32 Virtual pins. @vshymanskyy please update doc. It is not documented anywhere.

Thank you, Dmitriy. if I add the DEFINITION as you indicate It works as I expect, I mean using the V35. I ran out of physical pins using the ESP8266, so I am looking into this new kid of the block. Anyway, problem solved. Blynk is addictive!

1 Like