Redbear BLE Nano 2

When do you anticipate including the BLE Nano 2 in your app?

Not planned currently.

However, Blynk ahs examples with BLEPeripheral library, which supports BLE Nano 2, so it should just work.

I will look into that. Thank you.

Hi @belton,
did you figure out how to use nano 2 with Blynk properly? Can you please share examplary code?
Best regards,
Christian

No. I have not yet. It’s been put on the back burner for a while now. I’ll let you know if I do figure something out. Let me know if you do first.

Don`t get it running… tried all day
Nano 2 connects to cellphone properly, but not to Blynk…

@CMagnus, @belton You can try same technique as I described with BBC micro:bit:
http://help.blynk.cc/hardware-and-libraries/arduino/bbc-microbit-arduino-ide
Just select S132 SoftDevice.

The Blynk BBC microbit example will not compile (IDE 1.8.2):
1.) type ‘Print’ is not a base type for type ‘BLESerial’
after deleting: “using Print::write;” from BLESerial:
2.) ‘BLE_ATTRIBUTE_MAX_VALUE_LENGTH’ was not declared in this scope
after changing the variable to a fixed value of 20:
3.) cannot declare variable ‘SerialBLE’ to be of abstract type ‘BLESerial’

Old libraries?

All set-up today. The issues already started with:
“Arduino\libraries\BLEPeripheral-0.4.0\src/nRF51822.h:15:30: fatal error: s110/ble_gatts.h: No such file or directory”
But I copied RFduino folder to src and renamed to s110. The other libraries are coming with your latest Blynk version (0.4.7).

I did not have to copy anything anywhere

1 Like

Ok… deleted all of Arduino IDE, installed again, including Nordic packages… works like charm. Thx a lot and sorry for the mess!

@CMagnus,

I don’t know if this will help or not but while tinkering with it one night, I was able to pull up the Nano 2 I have in the Bluetooth device list in Blynk with the SimpleControls sketch provided by Redbear. No connection was made because Blynk is not in that sketch. Hope this helps.

I’m designing a PCB right now for my project. But after I get that made and the components soldered in I’ll be trying to get this to work as well. Until then, keep me in the loop please.

Didn’t see the edit @CMagnus. Thanks

Nevermind! I got it to work. Not 100% certain how I fixed it.


Hello @vshymanskyy - I have a question if you don’t mind.

Can you confirm that in the Adruino IDE:
-the board is “redbear BLE nano 2”
-softdevice is S132
-programmer is CMSIS-DAP
-then from the tools menu you select NRF5 Flash Softdevice

And can you confirm on the Blynk Android app I select the BBC Microbit as the hardware?

I’ve tried that and nothing seems to happen. Below is a screen grab.

Any help would be appreciated! Thanks in advance.

-Bashir

You forgot to click Upload button on the toolbar I assume.
if the board is not listed in the App, you should pick “Generic Board”.