BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

"Reconnecting in 3s..." - Arduino Uno USB Serial connection issues

Socat never connects, exits, and continually loops through “Reconnecting in 3s…”.

Thank you to anyone who reads this, your help is appreciated!

Same issue as this previous post.
https://community.blynk.cc/t/reconnecting-in-3s-please-help/895

I have followed all instructions, which are fantastic btw, really great, including the video on this page
Arduino USB Serial

Arduino Uno via USB Serial (Mac OS Sierra)

MyComputer:scripts user$ ./blynk-ser.sh
       1 ports found. You can specify port manually using -c option
Select serial port [ /dev/tty.usbserial-A403CUA8 ]: /dev/tty.usbserial-A403CUA8
Resetting device /dev/tty.usbserial-A403CUA8...
[ Press Ctrl+C to exit ]
Connecting: GOPEN:/dev/tty.usbserial-A403CUA8,raw,echo=0,clocal=1,cs8,nonblock=1,ixoff=0,ixon=0,ispeed=9600,ospeed=9600,crtscts=0 <-> openssl-connect:blynk-cloud.com:8441,cafile=/Users/user/Documents/Arduino/libraries/Blynk/scripts/certs/server.crt,nodelay
2017/12/07 13:30:11 socat[4395] N opening character device "/dev/tty.usbserial-A403CUA8" for reading and writing
2017/12/07 13:30:11 socat[4395] N opening connection to LEN=16 AF=2 45.55.96.146:8441
2017/12/07 13:30:12 socat[4395] N successfully connected from local address LEN=16 AF=2 10.0.0.29:51782
2017/12/07 13:30:13 socat[4395] N trusting certificate, commonName matches
2017/12/07 13:30:13 socat[4395] N SSL connection using ECDHE-RSA-AES128-GCM-SHA256
2017/12/07 13:30:13 socat[4395] N SSL connection compression "none"
2017/12/07 13:30:13 socat[4395] N SSL connection expansion "none"
2017/12/07 13:30:13 socat[4395] N starting data transfer loop with FDs [5,5] and [8,8]
2017/12/07 13:30:35 socat[4395] N socket 2 (fd 8) is at EOF
2017/12/07 13:30:36 socat[4395] N exiting with status 0
Reconnecting in 3s...

I feel like I’m so close to connecting with the app, but not at all. There was another post that mentioned something about SoftwareSerials but I have no idea if this is still related.

  • do you have anything hooked up to the arduino tx and rx pins?

  • it is not possible to use serial monitor and usb script in the same time

Very much related… Since as mentioned, you cannot do two things across serial at the same time, if you want to have a Serial Monitor output while using the USB link (which effectively turns your PC and Arduino USB port into a “Network to Serial” adaptor), you need to convert other digital pins into a SoftwareSerial connection and use a TTL-USB adaptor and a separate Terminal program.

https://www.arduino.cc/en/Reference/SoftwareSerial

Hi Wanek (and Gunner),

Thanks for looking at this.

I disconnected everything, and only had the USB into the Arduino, and guess what, it worked! Thank you. I was able to interact with the Arduino D13 led from the Blynk app. I was so happy, until…

It only worked once? The next day, I restarted my computer, turned on the Arduino, set up the connected via Terminal, and it’s now stuck on “reconnecting in 3s…” again.

My start up procedure was:

  • Check the USB port was showing up in Arduino IDE
  • Confirm the Serial Monitor was closed
  • Run the shell command: ~/Documents/Arduino/libraries/Blynk/scripts/blynk-ser.sh
  • Select the USB serial port: /dev/tty.usbserial-A403CUA8

Is that correct? Should that work? Is that the best way to set up?

i use windows, so have no idea how it should be on your os.

in windows, one can install a blynk plugin for starting the usb script directly from the arduino ide menu. maybe there is a similar way in linux?