Hi Guys,

Just started experiencing a problem with Blynk and a Raspberry Pi 2, using Raspbian.

When I run my code written in JavaScript and using Node, Blynk says -
OnOff mode
Connecting to SSL: 8441

But as soon as I start the Blynk App (version 1.7) on my iPhone and run my project page, the Raspberry says -
Disconnect blynk

Note, it did the same using version 1.6 of the App.

It then repeats indefinitely saying -
Connecting to SSL: 8441
Disconnect blynk
Connecting to SSL: 8441

Even when I strip the code back to the simplest, below, I get the same result -
var blynkLib = require(‘blynk-library’);
var AUTH = ‘xxxxxxxxxxxxxxxxxxxxxxxxxxxxx’;
var blynk = new blynkLib.Blynk(AUTH);

Issue only started in the past week. Worked before that.

I have tried to solve by upgrading the Blynk library, Node, the Blynk App and the Raspberry operating system. Have also tried a new authorization code. No change.

Any ideas?

Is that started after app. update?

Also may you try to create new dash and check if it will work with it?

The issue start before the update to 1.7

I created a new dash, as you suggested, and the issue appears to have gone. This is good but not good if I need to recreate the dash periodically? Would be great to understand what cause the issue. Any thoughts?

I have no idea what is “REARMING DISCONNECT” and where it is coming from. @vshymanskyy maybe you know?

Unfortunately the REARMING DISCONNECT issues has stated on the new dash. I added a 3 x value displays, 2 buttons, 3 x LED and 1 x history graph. Interesting that the LED displays did not function has they previously did. I.e. turn on, before the REARMING DISCONNECT issue reappeared. The other displays worked fine for the short period prior.

I think this is something related with Rasp. Could you please try use local server? It will help find what exactly is going wrong.

Is it possible to run the Blynk local server on a PC running Windows? I don’t have a second RPi readily available to act as a server. Any instructions available?

I have also just tried the following without success -

  1. Running the Blynk App on a different iOS device.
  2. Using 4G and not WiFi.
  3. Performing a complete new operating system install on the RPi

In all of the above cases the “REARMING DISCONNECT” occurred.

Yes, you can run it on PC. You just need java to be installed

I think I’ve found what triggers the “REARMING DISCONNECT” to occur. When ever I use a Value widget to simply display the state of a GPIO pin on the RPi the issue occurs. If I set the pin to “-” nothing or to a Virtual pin the error does not occur. I’ve have also found that the LED widgets no longer work as they did. These issues only appeared in the past 2 weeks.

Another disconnect issue - I’ve found that if the RPi experiences a short break in Wifi the Javascript/node throws an error and stops executing. I’m new to JS. How can I prevent the code from exiting, instead have it try to re-establish the Blynk connection?

I’ve included the Javascript/Node error mentioned above here. Every time the internet is disconnected the error happens. My project will have a RPi located in a remote location and internet drop offs will be common. I need the JS code to not crash out, as it does not when this occurs.

Any help would be greatly appreciated!!

throw Error(‘Uncaught, unspecified “error” event.’);
Error: Uncaught, unspecified “error” event.
at Error (native)
at emit (events.js:87:13)
at Blynk.error (/usr/local/lib/node_modules/blynk-library/blynk.js:569:8)
at null. (/usr/local/lib/node_modules/blynk-library/blynk.js:532:48)
at emit (events.js:107:17)
at TLSSocket. (/usr/local/lib/node_modules/blynk-library/blynk-node.js:180:14)
at TLSSocket.emit (events.js:129:20)
at net.js:459:14
at process._tickCallback (node.js:355:11)

I had the same issues with led widgets. They’ve changed how they work. this should help :+1:

thank, your right.
If button widget set the pin to “-” will REARMING DISCONNECT.
After chose pin correctly work very good.

I’m still having difficulty with the “rearming disconnect”. How did you go about fixing it?