Reading Timer Start and Stop settings

Hi All,
I know that Timer sends 1 and 0 at start and stop, and it is working for me.
The only thing is, if the hardware is restarted some where between timers start and stop time, you will end up with an “undefined” state.
I would like to be able to retrieve timers start and stop values, and evaluate the Timer state myself, it would give more control.

Is it possible to retrieve timer start and stop settings?

Benno

Yes, set a value Display with the latest Timer state and sync the value Display on hardware reset.

Yes that will work, but still a workaround. Since the server is evaluating the start/stop these values are stored on the server, and we should be able somehow to retrieve it directly from the server?

You can retrieve it from the server. The API gives you the status of everything. Pull down the details and parse the json data.

You can do that with SYNC command, it works also for timer starting from 0.16.2 server version. More details regarding sync here - http://docs.blynk.cc/#blynk-main-operations-state-syncing

When I Blynk.syncVirtual(timers Vpin) the value that is returned is always 0. Whether the timer is on or off.
Apparently it is not syncing the state of the timer.

@rmeder is the Timer actually working?

Are other pins syncing ok?

What timezone are you in and what time did you carry out the tests?

http://blynk-cloud.com/token/project for a timer on V29 gives “value”:“vw\u000029\u00001” when the timer is ON and “value”:“vw\u000029\u00000” when it is OFF but I haven’t tried syncing. Maybe see if the project gives the correct details via the API in a web browser.

Edit: http://blynk-cloud.com/token/pin/V29 gives [] when Timer is ON or OFF (so neither 0 or 1) and the same at http://docs.blynkapi.apiary.io/#reference/0/pin-actions/read-pin-value?console=1 so it doesn’t look like pin values for Timers are available yet. Any comments @Dmitriy?

@rmeder @Costas timer pin sync feature should work. @rmeder could you please confirm that timer was activated?

@Costas regarding HTTP GET for timer pin - could be a bug as timer wasn’t designed to store latest state. I’ll check.

@Costas Yes, Timer has been working well.
I am printing the value from the write param to terminal so I can see that the sync is working. The problem is that the value is always 0.
EST time zone. Tested between 3-4pm.

token/project does show that the timer shows the current value correctly as “vw\u000015\u00001”
token/pin/V15 results in []

@Dmitriy Yes, the timer is activated during testing.

@rmeder thanks for info! Issue is fixed. Will be deployed in few days. For local server will be released today.

Thank you! This will solve my issue also

still not deployed. And still old library on Particle… any chance of getting this going? Sorry to ask… just trying to decide path moving forward.

We want to add to add few additional features before deploy.