Raspberry Pi Zero W - connects to local server but does not connect with app on same network

I have a blynk local server and is working fine. I have tested it with arduinos is the past without problems. So now I have installed the blynk-library on the raspberrypi zero w (client). From the Linux folder I run command ./blynk --token=token# --server=mylocalipofserver . Everything seems to connect and I see that the pi reads


/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v0.4.6 on Linux

[5001] Connecting to 192.168.1.105:8442
[5018] Ready (ping: 11ms).

Then I look at my app and in the project it lists the device as “Wasn’t online yet”

I have tried all of the different type of raspberry pi boards but still can’t figure out why the app won’t see the zero w connected to the local blynk server. I have also verified that the app running on the phone is connecting to my local server and not the cloud.

Any ideas ?

The device choices in the app appear to determine connection options and pin designations, so any RPi choice should work.

The most obvious possible issue would be to confirm the app auth code matches what you are logging in with on the client side. Regenerate the auth (in the app, while connected to your Local Server) and try again.

1 Like