Problem with Nodemcu

Hi! I am experiencing a very strange thing. I have a blynk app whith 2 nodemcu. The one is working as expected. The second one when uploading programm from arduino is working fine. But when i unpluge it and connect it to external power, it wont connect to blynk server. Can someone help me with this?

1 Like

Is it exactly the same code? Same power supply?

Is it connecting to Blynk when its connected to the PC?

Are you using different Blynk auth codes on the two devices?


It is not same power. When connected to pc power is usb from pc and external power is usb from home. Same code. I use different auth for every nodemcu but use the same blynk app. I tried wifi manager or simple connection but same result. When connecting to home power supply refuses to Connect to blynk…

Very strange… Problem solved… I disconnect magnetic switch from nodemcu… Power on Nodemcu and magic… connected… Connect again switch… Everything works Normal… Thank You for your interest…

Let me guess, the magnetic switch was connected to either D3 (GPIO0), D4 (GPIO2) or D8(GPIO15) ?


Yes D3… Is this a known problem?

Read this:

D3 (GPIO0) must be HIGH at boot, so your switch was probably connected across D3 and GND and closed at the time.


Thank you!!!