Problem with a blink on start

Hi all,
I need some help with my project.
I’ve a wemos d1 mini with which i want to pilot 12v solenoid valve (through ULN2003), trigger a flash (through 4n35) and blink a led.
I’ve tested circuit with led instead of valve and flash and the project on blynk run well as expected.
the problem is that all led connected to the board (even the one connected to a ULN2003 and 4n35) light up for a second when i connect wemos with USB cable then led goes out and they respond to the app.
I’ve tested even with a TIP120 instead of the ULN2003 but with the same problem. also i’ve put a led connected to D0 port to D8 and leds light up on start.
Any suggestion on how to remove this “blink”?
Thank in advance

This is the base code:

#define BLYNK_PRINT Serial
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>
char ssid[] = "Vodafone-nnn";
char pass[] = "nnnn";
char auth[] = "nnnn";
void setup()
  // Debug console
  Blynk.begin(auth, ssid, pass);
void loop()

Blynk v.0.6.1
Board manager:
ESP8266 v.2.7.4

You should use virtual pins instead of digital ones in the app, and choose suitable pins on your Wemos (note that the link below references GPIO numbers, which aren’t the same as the “D” numbers screen printed on to the Wemos)…

Is this going to be a device for freeze-frame photography?


Thanks for the reply.
Oh, I’ve to try to use V pins.
I’ll make a simply sketch just for a check.
Yes, it is for water drop photography.

Ok, you’re link is helping me.
On D1 I don’t have those blinking…i have to check if I have enough “safe” pin for my purpose.

Are you using a valve to release the water drops?


Yes, I’ve bought a 5€ valve on Amazon…i don’t know if it is good, if not I’ll buy a Shako Pu220ar.
For my problem I found that only D1 & D2 are low on boot without oscillation so I want to try a shift register…maybe I can run all the sketch through it

I’m nit sure what exactly you’re referring to when you say “shift register”.
Have you switched to virtual pins, and are you using a pinMode and digitalWrite in your void setup?


Hi Pete,
with shift register i’m refering to the 74hc595n component, with this i can put a “barrier” between weimos and components.
Only changing to virtual pins don’t have solved the problem.
if you look at the link you have posted in youre first comment there is this image

GPIO 4 & 5 are LOW during boot but 12, 13 & 14 are HIGH for 100ms then LOW.
if i put a led or other connected to GPIO 12, 13 & 14 when i connet the USB cable they are put HIGH an then LOW so it is a hardware issue and not of the sketch.

This is a video i’ve made with this issue and as you can hear from the windows sound it blink on boot.

I hope it is all clear anyway despite my bad english.

I’ve worked with ESP8266 devices for over 3 years, and I’m certain that choosing appropriate pins, having pinMode and digitalWrite commands at the start of your void setup, and using virtual pins in Blynk will solve the pro you are having.

If you think that taking another route is the best option then go for it, although my advice would be to use an ESP32 based board.


1 Like

I’ll try it again…maybe this time I will have more fortune

Take a look at the this website. It shows you which GPIO pins are safe to use in the project and also shows the pinouts for your board (Wemos d1 mini).

ESP8266 Pinout Reference: Which GPIO pins should you use? | Random Nerd Tutorials

According to your original post, I figure that you need three pins from the board. I would suggest that you use GPIO4 and GPIO5 for the solenoid and the flash, since they require to be off on boot. For the led, You could use any one of the GPIO12, GPIO13, GPIO14 pins( the led will blink upon boot for ~100ms, but after that it would work properly).